Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Webview not displaying entire local html file
Started by guy.stockwell Mar 06 2018 04:16 AM

3 replies to this topic
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

guy.stockwell

[GLOBAL: userInfoPane.html]
guy.stockwell
  • Contributor

  • 105 posts
  • Corona SDK

On some IOS large phones I have an intermittent issue with viewing a local html file in a native.webview. I has only happened on a few phones, but essentially it will display only one screens worth and no more. Sometimes it displays the entire page and I can scroll, but most times it cuts off at the bottom of the first screen. Hope that makes sense! Any ideas?

I have a video illustrating the behavior. https://1drv.ms/v/s!AkiUpZbgYLTWifAtAhqUHsJPHlCJvA



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,534 posts
  • Enterprise

Hi Guy.  I tried to view the video but it was forcing me to log in to Microsoft's OneDrive which I do not have an account for.  Can you share it via a video sharing service or use a URL that doesn't require a login?

 

Thanks

Rob



[TOPIC: post.html]
#3

vp1

[GLOBAL: userInfoPane.html]
vp1
  • Observer

  • 7 posts
  • Corona SDK

The same issue occurred checking for solution. The scroll is not working and html page content is not showing fully. It works on iPhone 7 plus but not on iPhone 7. 



[TOPIC: post.html]
#4

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,534 posts
  • Enterprise

We are going to need to see the code for your webView (and HTML source) to help with this.  Please share it with us.

 

Rob




[topic_controls]
[/topic_controls]