Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Run Project error
Started by rollerband Sep 27 2017 04:28 AM

15 replies to this topic
winerror 2 the system cannot find the fi
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

rollerband

[GLOBAL: userInfoPane.html]
rollerband
  • Observer

  • 23 posts
  • Corona SDK

Hi ) Help me pleaze - i have an error on Run Project state
 
I have already reinstalled the corona SDK and the Sublime text 3 (sublime text 2) a couple of times, but the problem has not gone anywhere
 
 
Here console log:
 
[WinError 2] The system cannot find the file specified
[cmd: ["'C:\\Program Files (x86)\\Corona Labs\\Corona\\Corona Simulator.exe'", '/singleton', '/no-console', 'D:\\GIT_INCURSION\\new Game Incursion\\main.lua']]
[dir: D:\GIT_INCURSION\new Game Incursion\src]
[path: C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\ProgramData\chocolatey\bin;D:\Program Files\Git\cmd;C:\Program Files (x86)\Skype\Phone\;D:\Program Files\TortoiseGit\bin;C:\Program Files (x86)\GtkSharp\2.12\bin]
[Finished]


[TOPIC: post.html]
#2

yvandotet

[GLOBAL: userInfoPane.html]
yvandotet
  • Contributor

  • 184 posts
  • Corona SDK

Same for me.

 

One solution is to open the corona simulator 

 

( "C:\Program Files (x86)\Corona Labs\Corona SDK\Corona Simulator.exe" )

 

and select your project. Then click on File > open in editor.



[TOPIC: post.html]
#3

chandrashekhar.chaudhari

[GLOBAL: userInfoPane.html]
chandrashekhar.chaudhari
  • Observer

  • 5 posts
  • Corona SDK

But till yesterday, I was testing my apps by running them in Sublime Text 3 using run project. But now this is not working for me too.

 

As you have said, I have run it your way, I find it a longer route.

 

Please suggest how I can run my projects using Corona Editor in Sublime Text 3



[TOPIC: post.html]
#4

hanhatlinh91vn

[GLOBAL: userInfoPane.html]
hanhatlinh91vn
  • Enthusiast

  • 32 posts
  • Corona SDK

Same for me. 



[TOPIC: post.html]
#5

chandrashekhar.chaudhari

[GLOBAL: userInfoPane.html]
chandrashekhar.chaudhari
  • Observer

  • 5 posts
  • Corona SDK

But surprisingly I do not face this problem on my HP Laptop, both my Desktop & Laptop have 64 Bit Windows 7 OS. And both have the latest builds of Corona SDK and Sublime Text 3.

 

One observation though is that on my desktop, I had faced a peculiar problem before the above issue started. Any changes I made and ran the Run Project in Sublime Text 3 with the Simulator open then the changes would not reflect and the simulator would close. On a second try at Run Project the Simulator would run, showing my changes.

 

My problem of above issue started after these incidences.

 

If anyone has a clue to what could have gone wrong would help.



[TOPIC: post.html]
#6

davide.rivolta88

[GLOBAL: userInfoPane.html]
davide.rivolta88
  • Observer

  • 11 posts
  • Corona SDK

Hi, I started experiencing this error today too!

Corona Editor version is 1.7.0, I don't have the issue with another pc with an older version.

This is overcomplating the usual development workflow.



[TOPIC: post.html]
#7

Bektur

[GLOBAL: userInfoPane.html]
Bektur
  • Contributor

  • 150 posts
  • Corona Staff

Hey guys,

 

We've just pushed Corona Editor 1.7.1 which fixes an issue where 'Run Project' didn't work on Windows



[TOPIC: post.html]
#8

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

Sorry about that, I made a change but didn't adequately test it on Windows.  I've just pushed Corona Editor 1.7.1 which fixes the issue where Run Project doesn't work on Windows.

 

The update will show up in an hour or so (the Sublime Text Package Control system doesn't react instantly to updates).  You can quit and restart Sublime Text to check for updates or use Tools ▶ Command Palette... [Package Control: Upgrade Package]



[TOPIC: post.html]
#9

chandrashekhar.chaudhari

[GLOBAL: userInfoPane.html]
chandrashekhar.chaudhari
  • Observer

  • 5 posts
  • Corona SDK

Thanks a lot, Bektur and Perry Clarke, I have updated the Corona Editor to 1.7.1 on my Sublime Text 3, and I find the issue has been solved.

 

But there is still a small issue. I cannot re-run the Run Project if the simulator is open. I have to close the simulator to execute the Run Project Command again from the Corona Editor menu.

 

Of Course, simply saving the changes with an open simulator does reflect the changes I make to my project.

But, when an error pops up I have to close the simulator to Run Project again after correcting the error. 



[TOPIC: post.html]
#10

RedBeach

[GLOBAL: userInfoPane.html]
RedBeach
  • Corona Geek

  • 1,132 posts
  • Corona SDK

That problem is now happening on OS X...  I was able to identify the issue: it is when the path for the main.lua has spaces on it....

 

Just made a pull request on GitHub with the fix.



[TOPIC: post.html]
#11

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

Release 1.7.3 is available (quit and restart Sublime Text to get it) and it fixes the issue with spaces in drive names and filenames on macOS.



[TOPIC: post.html]
#12

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

@chandrashekhar.chaudhari  What operating system and version are you on?  



[TOPIC: post.html]
#13

chandrashekhar.chaudhari

[GLOBAL: userInfoPane.html]
chandrashekhar.chaudhari
  • Observer

  • 5 posts
  • Corona SDK

Sir, I am using Windows Home Premium 64 Bit with SP1. My System has 8 GB of RAM, 1 TB HDD, with 70% free space.

 

What happens actually is: When the simulator is on, if I click on Run Project, the console goes blank. Then if I click on the simulator, the simulator goes off. Then again if I click on Run Project the simulator reappears with the app showing on it and works normally.

But again, while its on, if I click on Run Project, the whole of above repeats.



[TOPIC: post.html]
#14

hfroth3

[GLOBAL: userInfoPane.html]
hfroth3
  • Observer

  • 14 posts
  • Corona SDK

Just started experiencing this problem today, same issue as above. Running Mac macOS Sierra v10.12.6. Updated Corona Editor today and 'Run Project' is now not working. Error msg below.

 

Cannot find executable Corona Simulator at path '/Applications/Corona/Corona Simulator.app/Contents/MacOS/Corona Simulator'



[TOPIC: post.html]
#15

roaminggamer

[GLOBAL: userInfoPane.html]
roaminggamer
  • Corona Geek

  • 7,585 posts
  • Corona SDK

@hfroth3,

 

Is your Corona installation at:  '/Applications/Corona/Corona Simulator.app/Contents/MacOS/Corona Simulator'

 
It might be at: '/Applications/Corona SDK/Corona Simulator.app/Contents/MacOS/Corona Simulator' or something like that.
 
The path changed earlier this year.


[TOPIC: post.html]
#16

hfroth3

[GLOBAL: userInfoPane.html]
hfroth3
  • Observer

  • 14 posts
  • Corona SDK

@roaminggamer 

 

Thank you for your quick response.

 

I think I figured out the issue for this. In past, I had to have the Application folder named 'CoronaSDK'. Now, it seems that in order for Sublime Text to pickup the path to the simulator, the application name cannot change after installation. For example, Corona installs build 3157 as 'Corona-3157'. When I changed it to 'CoronaSDK', I broke the path. After I reinstalled and left the name alone 'Corona-3157', it worked. I must have missed that detail earlier in year. Thanks again for help.




[topic_controls]
[/topic_controls]