Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

error "corona_sdk_simultator_pat"
Started by jorgeferrer1988 Sep 25 2017 08:57 AM

5 replies to this topic
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

jorgeferrer1988

[GLOBAL: userInfoPane.html]
jorgeferrer1988
  • Observer

  • 1 posts
  • Corona SDK

Used Mac OS, with Sublime Text 3 gives me all the time error "corona_sdk_simultator_path" I can not find the way to fix this error

2017.3135 version

Thanks in advance



[TOPIC: post.html]
#2

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

You can set the location of the Corona Simulator by doing this:

 

In Sublime's menu go to Sublime Text ▶ Preferences ▶ Settings and add this line to the JSON in the right hand panel:

"corona_sdk_simulator_path": "/Applications/Corona/Corona Simulator.app"


[TOPIC: post.html]
#3

jferrergil88

[GLOBAL: userInfoPane.html]
jferrergil88
  • Observer

  • 8 posts
  • Corona SDK

When I enter the command, I get the following error; Error trying to parse settings: Unexpected character, expected to comma or closing bracket in Packages / User / Preferences.sublime-settings: 4: 30



[TOPIC: post.html]
#4

jferrergil88

[GLOBAL: userInfoPane.html]
jferrergil88
  • Observer

  • 8 posts
  • Corona SDK

I have managed not to get the error but a to yes, still does not run the simulator, I am new to all this but I think I did it correctly

Attached Files



[TOPIC: post.html]
#5

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,779 posts
  • Enterprise

That file is in JSON format. There needs to be some valid separator between the string Perry provided and the other block of code you have. I would suspect you need a comma after the last ].

 

You can google a JSON validator and run your settings through it and see what it says is the issue.

 

Rob



[TOPIC: post.html]
#6

jferrergil88

[GLOBAL: userInfoPane.html]
jferrergil88
  • Observer

  • 8 posts
  • Corona SDK

Thanks Rob, for putting the comma to solve the problem



[topic_controls]
[/topic_controls]