Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Get plugin failed when building app. FirebaseDatabase plugin
Started by aswanin13 Sep 18 2017 03:20 PM

9 replies to this topic
firebase plugins corona android plugin
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

aswanin13

[GLOBAL: userInfoPane.html]
aswanin13
  • Observer

  • 3 posts
  • Corona SDK

I tried building the following app (https://github.com/scottrules44/firebaseDatabase-demo) with the firebase database plugin in it 
 
plugins =
    {
        ["plugin.firebaseDatabase"] =
        {
           publisherId = "tech.scotth", 
        },
    },
 
 
but the following message comes up. I have subscribed and activated the plugin. I have tried building my own app but with the same build settings and the same message comes up, even on other PCs.
 
A device build error occurred on the server.
 
Error: Get plugin failed.
 
Plugin: `shared.firebase.core`
Publisher: `com.coronalabs`
User Account: `########@wellington-college.school.nz`
 
BuildID: 59c0457fecfb1
---
Android build failed (5)
 
 
I tried building the app on a macbook and the error does not pop up, instead i got the following error message. I think I know how to fix this error (by downloading my own google services json file from my firebase) however even still this is on someone elses macbook and I cannot continue my project using his macbook.
 
Using custom build id from app bundle: 00000 (AppSettings.lua)
ERROR: Could not create build.properties:
Google Service settings file 'google-services.json' does not contain valid JSON. Please download a valid google-services.json from Project Settings in your Firebase control panel.
Android build failed (5) after 0 seconds
ERROR: Build Failed: Error code: 5
 
What could be the reasons that I am getting the "Get plugin failed" error?
 
All I want my app to do at the moment is to store data on the online firebase so that multiple phones could use my app and store simple data which they could extract for it. For example I might start of with something simple such as storing people's names and age when the enter it in a text box.


[TOPIC: post.html]
#2

Scott Harrison

[GLOBAL: userInfoPane.html]
Scott Harrison
  • Corona Geek

  • 1,820 posts
  • Enterprise

Try rebuilding a couple times, if that does not work email: support@coronalabs.com

[TOPIC: post.html]
#3

aswanin13

[GLOBAL: userInfoPane.html]
aswanin13
  • Observer

  • 3 posts
  • Corona SDK

Yea its been a few days since this. I dont think its a network error. Still coming up with the same error. Is there a possibility I have not subscribed to anything else from the corona marketplace to make this work? Or perhaps is there something I need to do with my corona account for this plugin to work? This is the first plugin I have used that I need to subscribe to. 



[TOPIC: post.html]
#4

Scott Harrison

[GLOBAL: userInfoPane.html]
Scott Harrison
  • Corona Geek

  • 1,820 posts
  • Enterprise

The "shared.firebase.core"  is a plugin that everyone should have access to, note the "shared" part. You do not need to activate anything but the plugin. Please contact support@coronalabs.com .



[TOPIC: post.html]
#5

aswanin13

[GLOBAL: userInfoPane.html]
aswanin13
  • Observer

  • 3 posts
  • Corona SDK

**FIX**

I simply had to download the 2017 version of the corona sdk simulator. The build was now successful, although I haven't tested it on a phone yet.

 

I was previously running the 2015 version.

 

I'll get underway with having a play around with firebase from tomorrow and will post back on the forum if needed.

 

Thanks for helping me understand a bit more about plugins Scott :) Will reply here if I run into anymore problems related with the plugin.



[TOPIC: post.html]
#6

Scott Harrison

[GLOBAL: userInfoPane.html]
Scott Harrison
  • Corona Geek

  • 1,820 posts
  • Enterprise

Glad I could help, I am always testing and building on the newest corona simulator.

[TOPIC: post.html]
#7

BK PANARA

[GLOBAL: userInfoPane.html]
BK PANARA
  • Enthusiast

  • 65 posts
  • Corona SDK

Hi @Scott Harrison,

I am getting same error with latest build 2019.3490.
Can you please help me solve this issue ?

Error :

A device build error occurred on the server. 

Error: Unhandled error while attempting to create DEX file(s):

PARSE ERROR:
class name (plugin/firebaseDatabase/LuaLoader) does not match path (plugin/firebaseDatabase/LuaLoader 6.class)
...while parsing plugin/firebaseDatabase/LuaLoader 6.class
1 error; aborting

Detailed error log


BuildID: 5d2ebde3220cf

Error code: 5

Thank you.



[TOPIC: post.html]
#8

BK PANARA

[GLOBAL: userInfoPane.html]
BK PANARA
  • Enthusiast

  • 65 posts
  • Corona SDK

@Rob , @Scott Harrison , @vlads

Guys Any update on this ?
 



[TOPIC: post.html]
#9

Scott Harrison

[GLOBAL: userInfoPane.html]
Scott Harrison
  • Corona Geek

  • 1,820 posts
  • Enterprise

This has been patched please rebuild



[TOPIC: post.html]
#10

BK PANARA

[GLOBAL: userInfoPane.html]
BK PANARA
  • Enthusiast

  • 65 posts
  • Corona SDK

Hi @Scott Harrison,

   ***** FIXED *****
Thank you For the Quick action. :)




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: firebase, plugins, corona, android, plugin