Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Support for High Sierra (Mac OSX 10.13)
Started by georg3 Jul 29 2017 11:39 AM

31 replies to this topic

[TOPIC CONTROLS]
Page 1 of 2 1 2
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

georg3

[GLOBAL: userInfoPane.html]
georg3
  • Observer

  • 22 posts
  • Corona SDK

Hi,

 

tried the search, couldn't find anything. When do you guys plan to support Mac OSX 10.13? Tried it after the upgrade and simulator gives me the warning, then dies.

 

Thanks



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,935 posts
  • Enterprise

Can you be more specific on what the warning is?  A screen shot might be helpful!

 

Rob



[TOPIC: post.html]
#3

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,935 posts
  • Enterprise

We had an engineer get the latest beta installed today and the simulator seems to run fine.  We will need screen shots and a better description of any errors/what you're seeing.

 

Rob



[TOPIC: post.html]
#4

georg3

[GLOBAL: userInfoPane.html]
georg3
  • Observer

  • 22 posts
  • Corona SDK

Hi Rob,

 

unfortunately the message doesn't appear any more, the app dies 1 seconds after launching it. I've tried the latest public and several of the last daily builds. Always the same behaviour.

 

The message seemed like it was coming from the app rather than from OSX, simply stating that 10.13 wasn't supported but I can try and go ahead.

 

Are there any logs I can check?

 

Thanks

Georg



[TOPIC: post.html]
#5

georg3

[GLOBAL: userInfoPane.html]
georg3
  • Observer

  • 22 posts
  • Corona SDK

Quick update: OSX logs show a couple of these:

 

[ERROR] Failed getting container for URL: <private>, error: <private>



[TOPIC: post.html]
#6

georg3

[GLOBAL: userInfoPane.html]
georg3
  • Observer

  • 22 posts
  • Corona SDK

Had to perform a clean uninstall, now the message is back. Using latest daily build: Corona 2017.3117

Attached Files



[TOPIC: post.html]
#7

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,935 posts
  • Enterprise

Does it work if you dismiss that dialog?  We don't formally support 10.13 yet, so that message is expected, but our internal testing shows that it should work. The only issue we've seen is with your "Recents" list showing up.

 

Rob



[TOPIC: post.html]
#8

georg3

[GLOBAL: userInfoPane.html]
georg3
  • Observer

  • 22 posts
  • Corona SDK

Same behaviour, I hit continue, the icon pops up and then the app dies. After the clean up and reinstall, the error doesn't show anymore. I can share the logs if you want.

 

BTW, the OSX version I'm on is 10.13 Beta (17A315i)



[TOPIC: post.html]
#9

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,935 posts
  • Enterprise

Can you look and see if you have a crash log? 

Can you send us more of the console log where you caught the error you did.

 

You can also try and run:

 

/Applications/Corona-3114/Corona Simulator.app/Contents/MacOS/Corona Simulator" -no-console YES

 

from the Terminal, substituting the version you are using in the command line and send us any output that shows up in the terminal window.

 

Thanks

Rob



[TOPIC: post.html]
#10

meyumeapps

[GLOBAL: userInfoPane.html]
meyumeapps
  • Observer

  • 8 posts
  • Corona SDK

Hi,

 

I'm getting the same error on the daily build from august 7th.

 

Running OSX High Sierra beta 5.

 

I'll try and get you some debug this evening, but basically it fails silently at launch. Same with the release version.



[TOPIC: post.html]
#11

meyumeapps

[GLOBAL: userInfoPane.html]
meyumeapps
  • Observer

  • 8 posts
  • Corona SDK

Running this:

 

/Applications/Corona-3117/Corona\ Simulator.app/Contents/MacOS/Corona\ Simulator -no-console YES

 

gives no output at all and silently dies



[TOPIC: post.html]
#12

georg3

[GLOBAL: userInfoPane.html]
georg3
  • Observer

  • 22 posts
  • Corona SDK

Just upgraded to latest BETA from app store - 10.13 Beta (17A330h). Still same behavior, running terminal command is the same as with meyumeapps.

 

Console logs attached

Attached Files



[TOPIC: post.html]
#13

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,935 posts
  • Enterprise

Are there any crash logs?

 

Look in ~/Library/Logs/DiagnosticReports for them

 

Rob

 



[TOPIC: post.html]
#14

georg3

[GLOBAL: userInfoPane.html]
georg3
  • Observer

  • 22 posts
  • Corona SDK

Unfortunately no crash logs



[TOPIC: post.html]
#15

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

This is very strange as Corona Simulator runs for me on 10.13 (with the exception of the Recent Projects list which is empty and which I am investigating).  The Console log you provided didn't show anything unusual.  I wonder what's different about our systems.

 

Have you tried removing the Simulator's preferences to see if that helps?

 

First save them in case they contain clues to the cause of the issue by running this command in a Terminal window:

defaults read com.coronalabs.Corona_Simulator > ~/sim.prefs

Then delete the preferences and try to run the Simulator again:

defaults delete com.coronalabs.Corona_Simulator

If the Simulator now runs, please PM me the saved preferences file and I'll try to see what was causing the issue.  If it doesn't, I guess we'll have to see if the next beta changes things.



[TOPIC: post.html]
#16

georg3

[GLOBAL: userInfoPane.html]
georg3
  • Observer

  • 22 posts
  • Corona SDK

I removed the preferences, the only thing that changed is that it asked me to login again. After that the app died as before.



[TOPIC: post.html]
#17

meyumeapps

[GLOBAL: userInfoPane.html]
meyumeapps
  • Observer

  • 8 posts
  • Corona SDK

Same for me after deleting preferences.

 

Asked me to login again and then died.



[TOPIC: post.html]
#18

meyumeapps

[GLOBAL: userInfoPane.html]
meyumeapps
  • Observer

  • 8 posts
  • Corona SDK

Should also add that I'm running Xcode 9 BETA 4.



[TOPIC: post.html]
#19

meyumeapps

[GLOBAL: userInfoPane.html]
meyumeapps
  • Observer

  • 8 posts
  • Corona SDK

Retested with Xcode 9 BETA 5 - no change, silently dies.



[TOPIC: post.html]
#20

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

The way recent file lists are stored has changed in 10.13 and I had to remove the cache files to get the Recent Projects list working in my installation (apparently there's a bug in the OS when it converts the old cache format to the new).  Since this is the only issue I've seen so far I'm going to suggest you do the same and see if this is all related somehow.

 

To remove the Recent Files cache for the Corona Simulator run this command in a Terminal window (best to copy and paste it):

rm -v ~/Library/Application\ Support/com.apple.sharedfilelist/com.apple.LSSharedFileList.ApplicationRecentDocuments/com.coronalabs.corona_simulator.sfl*

The star at the end is correct, there maybe old and new versions of the cache file.  Let me know what it prints in the Terminal window when you run it.  Then restart macOS 10.13 (to clear the in-memory cache) and try to run the Simulator again.



[TOPIC: post.html]
#21

meyumeapps

[GLOBAL: userInfoPane.html]
meyumeapps
  • Observer

  • 8 posts
  • Corona SDK

Hi,

 

This got printed:

 

/Users/scottwilson-billing/Library/Application Support/com.apple.sharedfilelist/com.apple.LSSharedFileList.ApplicationRecentDocuments/com.coronalabs.corona_simulator.sfl

 

I then restarted.

 

Sadly it still dies immediately after launch :(

 

Thanks for the suggestion though



[TOPIC: post.html]
#22

georg3

[GLOBAL: userInfoPane.html]
georg3
  • Observer

  • 22 posts
  • Corona SDK

The way recent file lists are stored has changed in 10.13 and I had to remove the cache files to get the Recent Projects list working in my installation (apparently there's a bug in the OS when it converts the old cache format to the new).  Since this is the only issue I've seen so far I'm going to suggest you do the same and see if this is all related somehow.

 

To remove the Recent Files cache for the Corona Simulator run this command in a Terminal window (best to copy and paste it):

rm -v ~/Library/Application\ Support/com.apple.sharedfilelist/com.apple.LSSharedFileList.ApplicationRecentDocuments/com.coronalabs.corona_simulator.sfl*

The star at the end is correct, there maybe old and new versions of the cache file.  Let me know what it prints in the Terminal window when you run it.  Then restart macOS 10.13 (to clear the in-memory cache) and try to run the Simulator again.

 

It failed, apparently there are no cached files for me



[TOPIC: post.html]
#23

georg3

[GLOBAL: userInfoPane.html]
georg3
  • Observer

  • 22 posts
  • Corona SDK

Retested with Xcode 9 BETA 5 - no change, silently dies.

 

Just upgraded to Beta 7 (17A352a), same issue



[TOPIC: post.html]
#24

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

Can you try Daily Build 2017.3126?  It's a longshot but the fix to Recent Projects in the Welcome window is in the right area.



[TOPIC: post.html]
#25

meyumeapps

[GLOBAL: userInfoPane.html]
meyumeapps
  • Observer

  • 8 posts
  • Corona SDK

Hi,

 

Still crashes for me with the latest build.

 

Cheers

Scott




[topic_controls]
Page 1 of 2 1 2
 
[/topic_controls]