Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Why wont my Chartboost ads work?
Started by r_burmeister Mar 24 2017 07:28 AM

- - - - -
1 reply to this topic

Best Answer r_burmeister , 24 March 2017 - 07:36 AM

Just kidding. I figured it out already. I was testing on Android and it notes on the documentation that you need to use the latest daily build. So anybody who has this issue, just download the latest version of Corna Simulator.

[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

r_burmeister

[GLOBAL: userInfoPane.html]
r_burmeister
  • Observer

  • 5 posts
  • Corona SDK

I purchased the Chartboost Plugin and set everything up on the Chartboost side of everything. Here is my code:

 

    local function adListener( event )
        if ( event.isError ) then
            display.newText( sceneGroup, event.response, _CX, _CY - 100, _FONT, 18 )            
        end


        if ( event.phase == "init" ) then  -- Successful initialization
            -- Pre-load the "more apps" screen
            chartboost.load( "interstitial" )
        elseif ( event.phase == "loaded" ) then


            display.newText( sceneGroup, "loaded", _CX, _CY + 100, _FONT, 18 )


        end


        display.newText( sceneGroup, "in function", _CX, _CY + 200, _FONT, 18 )
    end


    chartboost.init( adListener, { appId = "*******", appSig = "********" } )

Chartboost is definitely imported in this scene, and it's properly in the build settings. I call 

chartboost.show( "interstitial" )

 when the character dies, but the function is never called. I have added texts so I can see the messages on my phone, but none ever show up. Thanks for any help.

 



[TOPIC: post.html]
#2

r_burmeister

[GLOBAL: userInfoPane.html]
r_burmeister
  • Observer

  • 5 posts
  • Corona SDK

  Best Answer

Just kidding. I figured it out already. I was testing on Android and it notes on the documentation that you need to use the latest daily build. So anybody who has this issue, just download the latest version of Corna Simulator.




[topic_controls]
[/topic_controls]