Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

[ANDROID] App stops at Vungle ads.init line
Started by jrvwagner Dec 18 2016 05:46 PM

2 replies to this topic
vungle android ads plugin

Best Answer Rob Miracle , 19 December 2016 - 06:41 AM

Hi Jose. Please use code formatting when posting code (the blue <> button in the row with Bold, Italic, etc.)

 

We need to see where you are defining all of your app ID's and the provider variable. Though I think the problem may be the "" around "vungleAppIDAndroid". I suspect you want a variable there and variables are not inside quotes.

 

Rob

[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

jrvwagner

[GLOBAL: userInfoPane.html]
jrvwagner
  • Observer

  • 3 posts
  • Corona SDK

The code works on IOS, but on Android the app stops when reach vungle ads.init line

 

I would appreciate your support.

 

Android 6.0

 

- build. settings

 

["CoronaProvider.ads.vungle"] = {
            publisherId = "com.vungle"
        },

 

- main.lua

        if platform == "iPhone OS" then
            ads.init(provider, bannerAppIDiOS, adListener)
            ads.init(provider, interstitialAppIDiOS, adListener)
            ads.init("vungle", "vungleAppIDiOS", vungleAdListener)
        elseif platform == "Android" then
            ads.init(provider, bannerAppIDAndroid, adListener)
            ads.init(provider, interstitialAppIDAndroid, adListener)
            ads.init("vungle", "vungleAppIDAndroid", vungleAdListener)
        end

 

 

Regards,

 

 

Jose Roberto



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,471 posts
  • Enterprise

  Best Answer

Hi Jose. Please use code formatting when posting code (the blue <> button in the row with Bold, Italic, etc.)

 

We need to see where you are defining all of your app ID's and the provider variable. Though I think the problem may be the "" around "vungleAppIDAndroid". I suspect you want a variable there and variables are not inside quotes.

 

Rob



[TOPIC: post.html]
#3

jrvwagner

[GLOBAL: userInfoPane.html]
jrvwagner
  • Observer

  • 3 posts
  • Corona SDK

Thanks Rob for the reply.

 

I changed the AppId from a number to a variable when I posted to the forum and left the quotes by mistake. On the original code I've used the actual ID number.

I've found the error was caused by a conflict when loading other provider ads.

 

Regards,

 

Jose Roberto




[topic_controls]
[/topic_controls]