Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Recent Projects no longer available?
Started by ed91 Nov 23 2016 11:52 AM

9 replies to this topic

Best Answer ed91 , 29 November 2016 - 12:39 PM

I did not set it to None, but it has indeed been set to "none."  If I try to change it, it changes back to "None."  Googling around, it looks like some El Capitan users have exactly this issue with Recent Items resetting itself to "None" and have come up with a wide variety of arcane procedures to try to fix it, with varying success.  Looks like this is not a Corona issue at all, but an El Capitan issue!  Thanks for pointing me in the right direction.

[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

ed91

[GLOBAL: userInfoPane.html]
ed91
  • Observer

  • 29 posts
  • Corona SDK

I was using daily build 2991 on Mac OS Sierra, and I noticed as of this week I could no longer see Recent Projects when I started up.  I have since then opened up new projects and never see my recent projects anymore (either on the simulator startup screen or in the menu.)

 

I tried upgrading to 2992, the latest public build -- no change.

 

I tried using an old copy I had lying around from before the problem appeared -- still no change!

 

It must be something going wrong on my machine since it still happens on old versions of the simulator that didn't have that problem before.  I'm just not sure where to look.

 

I tried deleting the ~/Library/Saved Application State/com.coronalabs.Corona_Simulator.savedState but that didn't change anything.

 

Any ideas on what I can do to convince my machine to allow Corona to save recent projects like it used to?

 



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,539 posts
  • Enterprise

Did the loosing of recents come with a change to either upgrading macOS or updating the simulator?



[TOPIC: post.html]
#3

ed91

[GLOBAL: userInfoPane.html]
ed91
  • Observer

  • 29 posts
  • Corona SDK

I don't believe so.  I've done both upgrades (OS and simulator) but to the best of my memory the loss of recent projects happened some time after both those upgrades.



[TOPIC: post.html]
#4

ed91

[GLOBAL: userInfoPane.html]
ed91
  • Observer

  • 29 posts
  • Corona SDK

Possibly relevant -- this may have been happening before and I didn't notice it, but when I start up the simulator I get the following error in the log screen:

Nov 28 08:39:53.196 Activated fonts in 'Lato-Bold.ttf' (Lato-Bold)
Nov 28 08:39:53.376 Activated fonts in 'Lato-Regular.ttf' (Lato-Regular)
Nov 28 08:39:53.377 Copyright (C) 2009-2016  C o r o n a   L a b s   I n c .
                    	Version: 3.0.0
                    	Build: 2016.2991
Nov 28 08:39:54.245 parseHTTPDateFormat: missing date
Nov 28 08:39:54.248 ERROR: Runtime error
                    bad argument #1 to 'char' (invalid value)
                    stack traceback:
                    	[C]: ?
                    	[C]: in function 'char'
                    	?: in function <?:1205>
                    	[C]: in function 'gsub'
                    	?: in function 'unescape'
                    	?: in function '?'
                    	?: in function <?:496>


[TOPIC: post.html]
#5

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,539 posts
  • Enterprise

Let me ask Engineering.

 

Rob



[TOPIC: post.html]
#6

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,539 posts
  • Enterprise

Can you see your recents in the menu (File->Open Recent)?

 

Thanks

Rob



[TOPIC: post.html]
#7

ed91

[GLOBAL: userInfoPane.html]
ed91
  • Observer

  • 29 posts
  • Corona SDK

Nope, that's blank as well.



[TOPIC: post.html]
#8

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,539 posts
  • Enterprise

Thanks, continuing to investigate.



[TOPIC: post.html]
#9

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,539 posts
  • Enterprise

Have you by some chance gone into System Preferences -> General -> Recent Items and set it to none?



[TOPIC: post.html]
#10

ed91

[GLOBAL: userInfoPane.html]
ed91
  • Observer

  • 29 posts
  • Corona SDK

  Best Answer

I did not set it to None, but it has indeed been set to "none."  If I try to change it, it changes back to "None."  Googling around, it looks like some El Capitan users have exactly this issue with Recent Items resetting itself to "None" and have come up with a wide variety of arcane procedures to try to fix it, with varying success.  Looks like this is not a Corona issue at all, but an El Capitan issue!  Thanks for pointing me in the right direction.




[topic_controls]
[/topic_controls]