Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Making a build no longer works (Sierra & Xcode 8 Beta)
Started by jwwtaker Aug 25 2016 11:07 AM

17 replies to this topic

Best Answer lessmsios , 25 October 2016 - 03:41 PM

Just tried to update an app, got ERROR ITMS-90167: "No .app bundles found in the package". Renamed the ipa to zip and the .app is there.

 

macOS Sierra

Version 10.12.1 (16B2555)

 

Mac, used both the build option choice and the app loader from xcode->Open Designer Tool->Application Loader.

 

Xcode: Version 7.3 (7D175)

 

iOS SDK: 9.3

 

Build:

2016.2979

 

UPDATE: RESOLVED!

 

Updated to Xcode Version 8.0 (8A218a) and no problems.

[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

jwwtaker

[GLOBAL: userInfoPane.html]
jwwtaker
  • Contributor

  • 204 posts
  • Corona SDK

Using Xcode 8 beta and sierra when making builds this error always pops up

 

ERROR: code signing failed: /Users/aamir/Desktop/Test.app: replacing existing signature

/Users/aamir/Desktop/Test.app: resource fork, Finder information, or similar detritus not allowed

 
Has anyone experienced the same issue or figured out a clean way around this?  


[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,534 posts
  • Enterprise

What version of Xcode 8 beta and macOS Sierra are you using?



[TOPIC: post.html]
#3

saumitra.karandikar

[GLOBAL: userInfoPane.html]
saumitra.karandikar
  • Observer

  • 3 posts
  • Corona SDK

Hi Rob,

I have got same problem. Xcode version 8.0(8A218a) and macOS Sierra (10.12). 

 

Regards

Saumitra



[TOPIC: post.html]
#4

saumitra.karandikar

[GLOBAL: userInfoPane.html]
saumitra.karandikar
  • Observer

  • 3 posts
  • Corona SDK

Hi - it is resolved after upgrading to latest build 2949.

Regards,

Saumitra



[TOPIC: post.html]
#5

saumitra.karandikar

[GLOBAL: userInfoPane.html]
saumitra.karandikar
  • Observer

  • 3 posts
  • Corona SDK

Hi, apologies - nope, upgrading to latest Corona version did not get resolved the issue. I thought it got resolved because sample Corona projects started to build without an issue - however, when I tried to Build my existing projects, it failed with same error. And then I looked at some forums and did the following:

xattr -c <filename> e.g. xattr -c iTunesArtwork.png

 

Had to repeat for every single image file and no issues after that. (see attached screenshot)Attached File  screenshot.png   28.3KB   1 downloads

 

Good luck!

Sammy



[TOPIC: post.html]
#6

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,534 posts
  • Enterprise

We've fixed a couple of Xcode 8/macOS Sierra/iOS 10 problems in later daily builds. I would download the latest daily build and give it ago. The asset problem was fixed since 2949.

 

Rob



[TOPIC: post.html]
#7

jwwtaker

[GLOBAL: userInfoPane.html]
jwwtaker
  • Contributor

  • 204 posts
  • Corona SDK

I tried with the latest Daily build (from 10/6) and now the app submission gives me a different error every time.  

 

ERROR ITMS-90167: "No .app bundles found in the package"



[TOPIC: post.html]
#8

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,534 posts
  • Enterprise

Are you getting any errors while building?



[TOPIC: post.html]
#9

jwwtaker

[GLOBAL: userInfoPane.html]
jwwtaker
  • Contributor

  • 204 posts
  • Corona SDK

no the build process completes successfully with this message

 

iOS build succeeded in 36 seconds



[TOPIC: post.html]
#10

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,534 posts
  • Enterprise

You say its a different error every time, what are those errors?  I don't see how you could get a successful build when there are no app bundles found unless you grabbed the wrong file in Application Loader. You need to use the .ipa file that's output.

 

Rob



[TOPIC: post.html]
#11

jwwtaker

[GLOBAL: userInfoPane.html]
jwwtaker
  • Contributor

  • 204 posts
  • Corona SDK

I'm not sure why but when i use the application loader from the Xcode beta versus the actual Xcode release it works.  It's not a 'different error every time'.  I meant it's now a different error, that's happening every time which is 

ERROR ITMS-90167: "No .app bundles found in the package



[TOPIC: post.html]
#12

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,534 posts
  • Enterprise

Are you selecting the option to have Corona upload it for you?



[TOPIC: post.html]
#13

jwwtaker

[GLOBAL: userInfoPane.html]
jwwtaker
  • Contributor

  • 204 posts
  • Corona SDK

no i'm making the build in corona then using application loader to deliver it, as i've always done.



[TOPIC: post.html]
#14

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,534 posts
  • Enterprise

Can you try to use the option on the build dialog and see if that changes things?



[TOPIC: post.html]
#15

andrewvonpelt

[GLOBAL: userInfoPane.html]
andrewvonpelt
  • Observer

  • 9 posts
  • Corona SDK

some how that launched a different / 3rd version of application loader on my system which also works (as did the Xcode beta version of application launcher).  Thanks!



[TOPIC: post.html]
#16

lessmsios

[GLOBAL: userInfoPane.html]
lessmsios
  • Contributor

  • 170 posts
  • Corona SDK

  Best Answer

Just tried to update an app, got ERROR ITMS-90167: "No .app bundles found in the package". Renamed the ipa to zip and the .app is there.

 

macOS Sierra

Version 10.12.1 (16B2555)

 

Mac, used both the build option choice and the app loader from xcode->Open Designer Tool->Application Loader.

 

Xcode: Version 7.3 (7D175)

 

iOS SDK: 9.3

 

Build:

2016.2979

 

UPDATE: RESOLVED!

 

Updated to Xcode Version 8.0 (8A218a) and no problems.



[TOPIC: post.html]
#17

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,534 posts
  • Enterprise

After a quick google of the error message, this is happening frequently and there is a solution. It occurs with Xcode 7 on macOS Sierra. The solution seems to either a) build with Xcode 7 but upload with an Application Loader from Xcode 8 or b ) just update to Xcode 8.

 

Here's a link that talks about it:

 

http://stackoverflow.com/questions/37838487/error-itms-90167-no-app-bundles-found-in-the-package

 

Rob



[TOPIC: post.html]
#18

brainofsteel

[GLOBAL: userInfoPane.html]
brainofsteel
  • Enthusiast

  • 44 posts
  • Corona SDK

For anyone still trying to solve this problem: I had the same error message running macOS Sierra with Xcode 8.1 and Daily Build 2016.2983 and was able to get it to go away by disabling iCloud Drive.




[topic_controls]
[/topic_controls]