Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Google Play build randomly crashes using OneSignal, Google Analytics, Vungle plugins
Started by borderleap Jul 21 2016 05:57 AM

5 replies to this topic
androidc crash plugins
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

borderleap

[GLOBAL: userInfoPane.html]
borderleap
  • Contributor

  • 407 posts
  • Corona SDK

I'm having my app work just fine sometimes, then all of a sudden it'll crash, reporting that a plugin timed out or didn't load correctly...  Are you guys making changes on your end?  I need to get a build of this app up to Google Play like yesterday and am just waiting, not really knowing what to do...  Please help!

 

Here's one for OneSignal that just popped up randomly - total app crash:

I/ActivityManager(  544): Process com.borderleap.alphaomega (pid 29409) has died.
W/ActivityManager(  544): Scheduling restart of crashed service com.borderleap.alphaomega/com.onesignal.SyncService in 5000ms
W/WindowManager(  544): Failed looking up window
W/WindowManager(  544): java.lang.IllegalArgumentException: Requested window android.os.BinderProxy@41423838 does not exist
W/WindowManager(  544): 	at com.android.server.wm.WindowManagerService.windowForClientLocked(WindowManagerService.java:8669)
W/WindowManager(  544): 	at com.android.server.wm.WindowManagerService.windowForClientLocked(WindowManagerService.java:8660)
W/WindowManager(  544): 	at com.android.server.wm.WindowState$DeathRecipient.binderDied(WindowState.java:930)
W/WindowManager(  544): 	at android.os.BinderProxy.sendDeathNotice(Binder.java:449)
W/WindowManager(  544): 	at dalvik.system.NativeStart.run(Native Method)

And yet another for Vungle which just now apparently seems like Google Play Services not loading or something?  This one was random and led to app crash too:

V/Corona  (29115): > Class.forName: CoronaProvider.ads.vungle.LuaLoader
E/GooglePlayServicesUtil(29115): The Google Play services resources were not found. Check your project configuration to ensure that the resources are included.
D/libc    (29115): pt_debug : pthread_create->start_routine=0x40ed607d, tls=0x5740bf00, arg=0x56246e48
D/libc    (29115): pt_debug : __thread_entry->func=0x40ed607d
D/libc    (29115): , tls=0x5740bf00, arg=0x56246e48
W/dalvikvm(29115): threadid=14: thread exiting with uncaught exception (group=0x41027540)
V/Corona  (29115): < Class.forName: CoronaProvider.ads.vungle.LuaLoader
D/libc    (29115): pt_debug : pthread_create->start_routine=0x40ed607d, tls=0x5750bf00, arg=0x565456a8
D/libc    (29115): pt_debug : __thread_entry->func=0x40ed607d
D/libc    (29115): , tls=0x5750bf00, arg=0x565456a8
D/libc    (29115): pt_debug : pthread_create->start_routine=0x40ed607d, tls=0x5760bf00, arg=0x56246740
D/libc    (29115): pt_debug : __thread_entry->func=0x40ed607d
D/libc    (29115): , tls=0x5760bf00, arg=0x56246740
V/Corona  (29115): Loading via reflection: CoronaProvider.ads.vungle.LuaLoader
E/AndroidRuntime(29115): FATAL EXCEPTION: AsyncTask #1
E/AndroidRuntime(29115): java.lang.RuntimeException: An error occured while executing doInBackground()
E/AndroidRuntime(29115): 	at android.os.AsyncTask$3.done(AsyncTask.java:299)
E/AndroidRuntime(29115): 	at java.util.concurrent.FutureTask$Sync.innerSetException(FutureTask.java:273)
E/AndroidRuntime(29115): 	at java.util.concurrent.FutureTask.setException(FutureTask.java:124)
E/AndroidRuntime(29115): 	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:307)
E/AndroidRuntime(29115): 	at java.util.concurrent.FutureTask.run(FutureTask.java:137)
E/AndroidRuntime(29115): 	at android.os.AsyncTask$SerialExecutor$1.run(AsyncTask.java:230)
E/AndroidRuntime(29115): 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1076)
E/AndroidRuntime(29115): 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:569)
E/AndroidRuntime(29115): 	at java.lang.Thread.run(Thread.java:864)
E/AndroidRuntime(29115): Caused by: java.lang.IllegalStateException: The meta-data tag in your app's AndroidManifest.xml does not have the right value.  Expected 4242000 but found 8487000.  You must have the following declaration within the <application> element:     <meta-data android:name="com.google.android.gms.version" android:value="@integer/google_play_services_version" />
E/AndroidRuntime(29115): 	at com.google.android.gms.common.GooglePlayServicesUtil.n(Unknown Source)
E/AndroidRuntime(29115): 	at com.google.android.gms.common.GooglePlayServicesUtil.isGooglePlayServicesAvailable(Unknown Source)
E/AndroidRuntime(29115): 	at com.google.android.gms.common.GooglePlayServicesUtil.m(Unknown Source)
E/AndroidRuntime(29115): 	at com.google.android.gms.ads.identifier.AdvertisingIdClient.g(Unknown Source)
E/AndroidRuntime(29115): 	at com.google.android.gms.ads.identifier.AdvertisingIdClient.getAdvertisingIdInfo(Unknown Source)
E/AndroidRuntime(29115): 	at plugin.applovin.CoronaBeacon$1$1.doInBackground(CoronaBeacon.java:85)
E/AndroidRuntime(29115): 	at plugin.applovin.CoronaBeacon$1$1.doInBackground(CoronaBeacon.java:78)
E/AndroidRuntime(29115): 	at android.os.AsyncTask$2.call(AsyncTask.java:287)
E/AndroidRuntime(29115): 	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:305)
E/AndroidRuntime(29115): 	... 5 more

I do have a fully-working net connection on the phone...

 

Thanks,

Nate



[TOPIC: post.html]
#2

borderleap

[GLOBAL: userInfoPane.html]
borderleap
  • Contributor

  • 407 posts
  • Corona SDK

Can anyone at Corona help with this?  I'm at a loss...  wasted an entire day of development trying to debug this with no solution.  It's completely random when the crashes happen and looking at adb logcat it appears they all seem to stem with Google Play Services not loading (see previous post).



[TOPIC: post.html]
#3

borderleap

[GLOBAL: userInfoPane.html]
borderleap
  • Contributor

  • 407 posts
  • Corona SDK

UPDATE:  Ok, it seems I may have made some headway in figuring this out...  I've been on apparently somewhat spotty internet, but Google Play builds are still building successfully with the latest public build.  However, it appears as though some plugins - especially the Google Play Services one - are not being included in the build, even though the build is reporting to be successfully built.

 

What I did to test was simply switch on my iPhone's LTE hotspot, hook up my Macbook AND the tethered Android phone to use the hotspot, and then did a new build.  This time, the build worked and the app didn't crash on load.

 

Still interested to know if this is an issue for others or any insight Corona staff may have...

 

Thanks,

Nate



[TOPIC: post.html]
#4

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,697 posts
  • Enterprise

We are looking into this.



[TOPIC: post.html]
#5

borderleap

[GLOBAL: userInfoPane.html]
borderleap
  • Contributor

  • 407 posts
  • Corona SDK

Thanks Rob



[TOPIC: post.html]
#6

borderleap

[GLOBAL: userInfoPane.html]
borderleap
  • Contributor

  • 407 posts
  • Corona SDK

Hey guys, any updates??




[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: androidc, crash, plugins