Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Fuse and iOS - Black Screen issue
Started by elsoqo Jun 24 2016 01:27 AM

No replies to this topic
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

elsoqo

[GLOBAL: userInfoPane.html]
elsoqo
  • Enthusiast

  • 81 posts
  • Corona SDK

Hello all,

 

Having an issue with Fuse recently on my iOS builds, regarding rewarded video.  When a rewarded video is called, the screen darkens and there's a prompt asking the user if they want to view the rewarded video and get X reward.  Their two choices are 'okay' and 'no thanks.'

 

Here's the issue.  Hitting okay results in the ad being displayed, user getting their reward, and all that good stuff.  Hitting 'no thanks,' however, results in the black screen hanging around preventing user input to the app.  I don't see an error in the console that looks very helpful either, but if it's needed I can post the chunk where this happens.  This is also using build 2906.  

 

We are also having an issue where, again only on iOS, we are only getting rewarded video ads when we are calling for interstitials.  We tried using just fuse.show() as per documentation, and then tried forcing it with fuse.show({zone = "default"}), and it still only seems to be retrieving rewarded video and not interstitials.

 

Edit- Actually, we get that first issue on Android as well, where the prompt appears and hitting 'no thanks' causes the app to freeze.  So that particular one isn't just iOS, but we are receiving interstitials on Android.

 

Edit 2 - Alright, so we figured out a workaround for this issue, not really a solution, but it works for us.  We call fuse.load() a half second before calling fuse.show(), which seems to trick it into loading an interstitial.  We also managed to fix the prompt that was showing up by disabling it on our ad service's dash, turns out it was just taking a while to process the fact that it was disabled.




[topic_controls]
[/topic_controls]