Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Facebook Audience Network (fbAudienceNetwork) gets stuck on blank screen
Started by Mike Hempfling Apr 28 2016 06:50 AM

31 replies to this topic
fbaudiencenetwork facebook audience network plugin no ad blank screen

Best Answer Danny , 29 April 2016 - 05:09 AM

 

I had the same problem, its working fine now.

 

But now the ad loaded response shows a placementID "2110550390*****_808866605905972"[random placementID], which is not my placementID.

 

This thing happens when I try load ads continuously like below [ wild guess! not sure].

facebookLib.load("interstitial","MY_PLACEMENT_ID1"])
facebookLib.load("interstitial","MY_PLACEMENT_ID2"])

 

When this happens, it means we are using our placement id for the ad in question (5% of the time)

 

Thanks

[TOPIC CONTROLS]
Page 2 of 2 1 2
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#26

o.jacek

[GLOBAL: userInfoPane.html]
o.jacek
  • Observer

  • 20 posts
  • Corona SDK

My devices runs Android 9.0 and Android 8.1.

I have tested this on Corona 3466 and 3439. 



[TOPIC: post.html]
#27

sahil19.sindh

[GLOBAL: userInfoPane.html]
sahil19.sindh
  • Contributor

  • 136 posts
  • Corona SDK

Hello Rob, sorry to say, may be i am wrong but i remember i had similar issue when i tested sample code. I changed that code to get rid of race condition. I provide a good gap between both init and load. Try to use load on a button click after init is successful but i remember i had this issue. When i turned this to paid plugin the problem was gone. And now i am using FAN in almost every app and it works excellent.
I do think there is some issue may be in sample, not sure.

[TOPIC: post.html]
#28

o.jacek

[GLOBAL: userInfoPane.html]
o.jacek
  • Observer

  • 20 posts
  • Corona SDK

It doesn't work in my private app either. When I wait 1 min to load SDK I get same result.



[TOPIC: post.html]
#29

shivapp

[GLOBAL: userInfoPane.html]
shivapp
  • Enthusiast

  • 40 posts
  • Corona SDK

Are there any updates to the "You must wait for the 'init' event before calling other API methods" error? Does the free plugin not work? I am getting the same error now too on the free plugin. I get this error with the same build that o.jacek has put a link to above. I am on Corona daily build 3468.



[TOPIC: post.html]
#30

shivapp

[GLOBAL: userInfoPane.html]
shivapp
  • Enthusiast

  • 40 posts
  • Corona SDK

Below is what I see in the console log for the sample app . It starts saying the initialization was successful followed by the annoying error message. Please help.

 

Mar 12 11:33:08.915 SM-G935V: Facebook Audience Network event: initialization s
Mar 12 11:33:08.916 uccessful
Mar 12 11:33:14.134 SM-G935V: ERROR
Mar 12 11:33:14.134 : fbAudienceNetwork.load(adUnitType, options]), You must wait for the 'init' event before calling other API methods


[TOPIC: post.html]
#31

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 852 posts
  • Corona Staff

Hello, shivapp.
Thanks for bringing it up. Please, test it again (no need to rebuild), should work now.



[TOPIC: post.html]
#32

o.jacek

[GLOBAL: userInfoPane.html]
o.jacek
  • Observer

  • 20 posts
  • Corona SDK

The error has disappeared. Now I have new error: 

ERROR: fbAudienceNetwork.show(adUnitType [, options]), placementId 'XXXXXXXXXX_XXXXXXX' not loaded

and still no ads.

 

(XXXXX_XXXX its my valid placement id)




[topic_controls]
Page 2 of 2 1 2
 
[/topic_controls]

Also tagged with one or more of these keywords: fbaudiencenetwork, facebook audience network, plugin, no ad, blank screen