Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

OpenSSL Google Security Alert
Started by greg brady Mar 31 2016 04:54 AM

- - - - -
40 replies to this topic
openssl google warning

Best Answer Perry Clarke , 19 May 2016 - 11:19 AM

We've just published the latest version of the OpenSSL plugin.  You'll need Daily Build 2016.2883 to use it.
 
It implements the following:

  • Support latest version of OpenSSL (1.0.2h)
  • Support latest LuaSec (0.6)
  • Support latest LuaSocket (3.0rc1)
  • Add new platforms: iOS Simulator, tvOS, tvOS Simulator

There are also improved sample apps at https://github.com/coronalabs/plugins-sample-openssl

 

This is a complex update due to the number of moving parts so please report any bugs you find (with Lua code to reproduce them, of course).

[TOPIC CONTROLS]
Page 2 of 2 1 2
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#26

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,895 posts
  • Enterprise

Just an update on this. Yesterday's daily build included the new LuaSocket 3.0 release. This is a prerequisite for updating the plugin. While I can't promise any dates, we are hoping the plugin will be updated sooner than later.

 

Rob



[TOPIC: post.html]
#27

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

  Best Answer

We've just published the latest version of the OpenSSL plugin.  You'll need Daily Build 2016.2883 to use it.
 
It implements the following:

  • Support latest version of OpenSSL (1.0.2h)
  • Support latest LuaSec (0.6)
  • Support latest LuaSocket (3.0rc1)
  • Add new platforms: iOS Simulator, tvOS, tvOS Simulator

There are also improved sample apps at https://github.com/coronalabs/plugins-sample-openssl

 

This is a complex update due to the number of moving parts so please report any bugs you find (with Lua code to reproduce them, of course).



[TOPIC: post.html]
#28

Rob...

[GLOBAL: userInfoPane.html]
Rob...
  • Contributor

  • 329 posts
  • Corona SDK

Ok cool. .. Just as I'm half way through updating my apps.. Tomorrow, I'll fly through the last 10 which I haven't touched yet and see if I have any problems.

[TOPIC: post.html]
#29

Rob...

[GLOBAL: userInfoPane.html]
Rob...
  • Contributor

  • 329 posts
  • Corona SDK

I'm assuming I leave things as they were wth the old plugin. IE cipher, mime et. Will be just the same and build settings.?

[TOPIC: post.html]
#30

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,895 posts
  • Enterprise

Perry can provide a more specific answer, but I've not heard of any breaking changes. No discussion of migration needs etc. So I'm assuming other than needing daily build 2883, it should be transparent.

 

You can always look at the sample app and compare it to your use.

 

Rob



[TOPIC: post.html]
#31

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

That is the intention.

 

There was an issue where trying to require plugin_luasec_https didn't appear to work at all and I don't know how people were managing to use it.  You should explicitly require it like you would expect:

local plugin_luasec_https = require('plugin_luasec_https')

and then call its methods on the returned table (previously that require was returning a boolean so none of the methods were accessible).



[TOPIC: post.html]
#32

Brad Shin

[GLOBAL: userInfoPane.html]
Brad Shin
  • Observer

  • 23 posts
  • Corona SDK

Corona Enterprise Version -> page not found.



[TOPIC: post.html]
#33

Alan PlantPot

[GLOBAL: userInfoPane.html]
Alan PlantPot
  • Contributor

  • 917 posts
  • Corona SDK

Corona Enterprise Version -> page not found.

 

This is also the case for me.



[TOPIC: post.html]
#34

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,895 posts
  • Enterprise

I'll see about getting it fixed.



[TOPIC: post.html]
#35

Rob...

[GLOBAL: userInfoPane.html]
Rob...
  • Contributor

  • 329 posts
  • Corona SDK

I can safely say that updating Corona to this latest build still read the encrypted game/data save file. I also uploaded three apps with this update and the warning on GooglePlay has gone. Bravo.



[TOPIC: post.html]
#36

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

Nice!  Thanks for the feedback ... the update was a long road :)



[TOPIC: post.html]
#37

Rob...

[GLOBAL: userInfoPane.html]
Rob...
  • Contributor

  • 329 posts
  • Corona SDK

Yes thanks for getting it done. Much easier than what i had done already (which i still have to finish doing on 20 apps)

I notice the ability to override the print function has come back thankfully too.



[TOPIC: post.html]
#38

yuval_forish

[GLOBAL: userInfoPane.html]
yuval_forish
  • Enthusiast

  • 67 posts
  • Corona SDK

Hi,

Is there a solution from Corona on this one ?

11-July is very near....

 

Yuval F



[TOPIC: post.html]
#39

Alan PlantPot

[GLOBAL: userInfoPane.html]
Alan PlantPot
  • Contributor

  • 917 posts
  • Corona SDK

It was fixed about 2 weeks ago, see Perry Clarke's post above from 19th May:

 

We've just published the latest version of the OpenSSL plugin.  You'll need Daily Build 2016.2883 to use it.

 



[TOPIC: post.html]
#40

DragonGameStudio

[GLOBAL: userInfoPane.html]
DragonGameStudio
  • Enthusiast

  • 65 posts
  • Corona SDK

cool, i uploaded one of my project to google, and the alert was gone, nice solution

but now i am facing new problem, since the facebook was migrating to facebook v4,

i must change the facebook plugin to facebook v4, because it cannot download the facebook plugin,

and when i try to use it, i am facing login problem with the new facebook v4 plugin

like shown in this forum https://forums.coronalabs.com/topic/61308-having-problems-getting-the-facebook-v4-ios-plugin-to-login-possibly-due-to-ats/

 

is that possible to have this new plugin with corona sdk 2015.2731 so i still can use the old facebook plugin

 

thank you



[TOPIC: post.html]
#41

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,895 posts
  • Enterprise

I believe the legacy facebook plugin should still be there and it should work with the latest builds.




[topic_controls]
Page 2 of 2 1 2
 
[/topic_controls]