Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Removing Fuse
Started by tonygod Mar 07 2016 03:39 PM

4 replies to this topic
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

tonygod

[GLOBAL: userInfoPane.html]
tonygod
  • Contributor

  • 197 posts
  • Corona SDK

I have removed all references to Fuse from my build.settings and I am leaving the "Enable Analytics and Monetization" box unchecked, but I am noticing this in the console output when starting my app:
 
I/Corona  ( 2769): Platform: Nexus 7 / ARM Neon / 5.1.1 / NVIDIA Tegra 3 / OpenGL ES 2.0 14.01003 / 2016.2830 / English | US | en_US | en
V/Corona  ( 2769): > Class.forName: plugin.fuse.LuaLoader
V/Corona  ( 2769): > Class.forName: CoronaProvider.licensing.google.LuaLoader
V/Corona  ( 2769): < Class.forName: CoronaProvider.licensing.google.LuaLoader
V/Corona  ( 2769): Loading via reflection: CoronaProvider.licensing.google.LuaLoader

 

The plugin does not appear to actually be loading, which is good, but I am curious why it is attempting to load.

 

Also, I remember typing in some command in the terminal to make the "Enable Analytics and Monetization" checkbox show up, but I can't find the page with that command now so that I can reverse the action.  Is there a way to do it and should I?

 

Best regards,

Tony



[TOPIC: post.html]
#2

bjsorrentino

[GLOBAL: userInfoPane.html]
bjsorrentino
  • Veteran

  • 8,506 posts
  • Corona SDK

Hi Tony,

Try this...

defaults delete com.coronalabs.Corona_Simulator enableMonetization


[TOPIC: post.html]
#3

tonygod

[GLOBAL: userInfoPane.html]
tonygod
  • Contributor

  • 197 posts
  • Corona SDK

Not sure why, but it did not work:

Tonys-MacBook-Pro:Hoppy Naut tonygod$ defaults delete com.coronalabs.Corona_Simulator enableMonetization
2016-03-08 16:46:52.579 defaults[98467:9461119] 
Domain (com.coronalabs.Corona_Simulator) not found.
Defaults have not been changed.


[TOPIC: post.html]
#4

bjsorrentino

[GLOBAL: userInfoPane.html]
bjsorrentino
  • Veteran

  • 8,506 posts
  • Corona SDK

Hmmm, can you try this?

defaults delete com.coronalabs.Corona_Simulator debugMonetizationPlugin

Brent



[TOPIC: post.html]
#5

tonygod

[GLOBAL: userInfoPane.html]
tonygod
  • Contributor

  • 197 posts
  • Corona SDK

Yes, that worked.  The checkbox is no longer on the build dialog.  I am still seeing the "> Class.forName: plugin.fuse.LuaLoader" debug output, which is curious, but not a big deal for me.  Thank you, Brent!

 

Best regards,

Tony




[topic_controls]
[/topic_controls]