Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Fuse plugin - crash on pre-android 6 devices
Started by stanga Feb 25 2016 09:37 PM

2 replies to this topic
fuse android permissions
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

stanga

[GLOBAL: userInfoPane.html]
stanga
  • Contributor

  • 193 posts
  • Corona SDK

I am using build number 105.2799 to build for Android devices, and when I run my app on Android devices without Android 6 (android 5 and lower) I get the following crash:

 

W/System.err( 6298): java.lang.RuntimeException: java.lang.NoClassDefFoundError: com.ansca.corona.permissions.PermissionsServices
W/System.err( 6298): Java Stack Trace:
W/System.err( 6298):    plugin.fuse.LuaLoader.CheckAndAskForPermission(LuaLoader.java:89)
W/System.err( 6298):    plugin.fuse.LuaLoader.StartSession(LuaLoader.java:336)
W/System.err( 6298):    plugin.fuse.LuaLoader._startInternal(LuaLoader.java:268)
W/System.err( 6298):    plugin.fuse.LuaLoader._start(LuaLoader.java:315)
W/System.err( 6298):    plugin.fuse.LuaLoader.access$1800(LuaLoader.java:53)
W/System.err( 6298):    plugin.fuse.LuaLoader$_StartWrapper.invoke(LuaLoader.java:1386)
W/System.err( 6298):    com.ansca.corona.JavaToNativeShim.nativeResize(Native Method)
W/System.err( 6298):    com.ansca.corona.JavaToNativeShim.resize(JavaToNativeShim.java:378)
W/System.err( 6298):    com.ansca.corona.graphics.opengl.CoronaGLSurfaceView$CoronaRenderer.onSurfaceChanged(CoronaGLSurfaceView.java:378)
W/System.err( 6298):    com.ansca.corona.graphics.opengl.GLSurfaceView$GLThread.guardedRun(GLSurfaceView.java:1612)
W/System.err( 6298):    com.ansca.corona.graphics.opengl.GLSurfaceView$GLThread.run(GLSurfaceView.java:1378)
 
First of all, I am NOT using fuse in my code, and the check mark in the simulator for "Enable Monetization" is not checked, so why is fuse plugin even called?
 
Second, it looks like fuse updated their plugin according to Android 6 permission changes without considering the Android OS prior to 6 - which is most of Android users.
 
What is going on? Please help me get rid of this fuse madness and compile for Android.
 
Thanks


[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,300 posts
  • Enterprise

My first advice would be to update to 2830 where we are now supporting Android 6 and see if you still  have the problem. After that we can proceed to track down the problem.

 

Rob



[TOPIC: post.html]
#3

Michael W.

[GLOBAL: userInfoPane.html]
Michael W.
  • Contributor

  • 276 posts
  • Alumni

This should be fixed now. Please give your build another try -- though I encourage updating to the latest public release.




[topic_controls]
[/topic_controls]