Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Google Analytics - build error alongside advertisingId plugin
Started by borderleap Feb 23 2016 06:47 AM

3 replies to this topic
google analytics plugins error
[TOPIC CONTROLS]
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

borderleap

[GLOBAL: userInfoPane.html]
borderleap
  • Contributor

  • 407 posts
  • Corona SDK

I am getting a build error every time I try to build with the Google Analytics plugin installed.   I activated it via the Corona store awhile ago, but am still getting this error...  Is this due to needing to still wait for the plugin to activate in the Corona store?

Feb 23 09:37:11.467 ld: 6 duplicate symbols for architecture armv7
Feb 23 09:37:11.468 clang: error: linker command failed with exit code 1 (use -v to see invocation)
Feb 23 09:37:11.468 BUILD ERROR: There was a problem linking the app.


Check the console for more information.
Feb 23 09:37:11.494 iOS build failed (12)
Feb 23 09:37:11.785 ERROR: Build Failed: There was a problem linking the app.


Check the console for more information.


[TOPIC: post.html]
#2

borderleap

[GLOBAL: userInfoPane.html]
borderleap
  • Contributor

  • 407 posts
  • Corona SDK

Nevermind... problem solved.  

 

You should note in your docs that you can NOT have the advertisingId plugin alongside the Google Analytics plugin.  I was using GameAnalytics which required the following, but that was causing the above issue in my previous post.

["plugin.advertisingId"] = {
    publisherId = "com.coronalabs"
},


[TOPIC: post.html]
#3

bjsorrentino

[GLOBAL: userInfoPane.html]
bjsorrentino
  • Veteran

  • 8,506 posts
  • Corona SDK

I've asked the engineers to investigate why this might be an issue... I'll keep you posted.

 

Thanks,

Brent



[TOPIC: post.html]
#4

borderleap

[GLOBAL: userInfoPane.html]
borderleap
  • Contributor

  • 407 posts
  • Corona SDK

Thanks Brent.  I was able to successfully install the sample app with my tracking code, and it's working......

 

Here's my build.settings - plugins section for your reference:

plugins = {

    -- ALL
    ["plugin.OneSignal"] = {
        publisherId = "com.onesignal",
        supportedPlatforms = { iphone=true, android=true, ["android-kindle"]=false }
    },
    ["CoronaProvider.native.popup.social"] = {
        publisherId = "com.coronalabs"
    },
    ["plugin.googleAnalytics"] = {
        publisherId = "com.coronalabs",
        supportedPlatforms = { iphone=true, android=true, osx=true, win32=true }
    },

    -- iOS
    ["CoronaProvider.gameNetwork.apple"] = {
        publisherId = "com.coronalabs",
        supportedPlatforms = { iphone=true, ["iphone-sim"]=true }
    },
    ["plugin.iCloud"] = {
        publisherId = "com.coronalabs",
        supportedPlatforms = 
        {
            iphone = true,
            ["iphone-sim"] = true,
            ["mac-sim"] = true,
        },
    },

    -- Android
    ["CoronaProvider.gameNetwork.google"] = {
        publisherId = "com.coronalabs",
        supportedPlatforms = { android=true }
    },
    ["plugin.google.play.services"] = {
        publisherId = "com.coronalabs",
        supportedPlatforms = { android=true, ["android-kindle"]=true }
    },

    -- Amazon
    ["plugin.gamecircle"] = {
        publisherId = "COM_INNOVATIVELEISURE",
        supportedPlatforms = { ["android-kindle"]=true }
    }
},



[topic_controls]
[/topic_controls]

Also tagged with one or more of these keywords: google, analytics, plugins, error