Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Text wrapping not working on tvOS
Started by tonygod Jan 11 2016 05:42 PM

6 replies to this topic
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

tonygod

[GLOBAL: userInfoPane.html]
tonygod
  • Contributor

  • 196 posts
  • Corona SDK

I have many places in my code where i call newText with a width parameter and without a height parameter so that I get multi-line wrapped text.

 

On tvOS, the text is cropping and not wrapping.  If I set the height parameter, the wrapping works, but then my y coordinates are off.

 

Bug or behavior?



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,527 posts
  • Enterprise

Can you file a bug report for this please?

 

Thanks

Rob



[TOPIC: post.html]
#3

tonygod

[GLOBAL: userInfoPane.html]
tonygod
  • Contributor

  • 196 posts
  • Corona SDK

(Case 44613) Text does not wrap on tvOS when height=nil or height=0



[TOPIC: post.html]
#4

avlepel

[GLOBAL: userInfoPane.html]
avlepel
  • Contributor

  • 132 posts
  • Corona SDK

I have the same problem and wanted to report this today, you were faster - thanks!

[TOPIC: post.html]
#5

tonygod

[GLOBAL: userInfoPane.html]
tonygod
  • Contributor

  • 196 posts
  • Corona SDK

Is there any update on this issue?  It is still present in build 2836.

 

Best regards,

Tony



[TOPIC: post.html]
#6

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,527 posts
  • Enterprise

No news yet.



[TOPIC: post.html]
#7

tonygod

[GLOBAL: userInfoPane.html]
tonygod
  • Contributor

  • 196 posts
  • Corona SDK

I have confirmed this is fixed in 2016.2837




[topic_controls]
[/topic_controls]