Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Testflight crash on launch
Started by thassman Dec 21 2015 11:15 AM

6 replies to this topic
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

thassman

[GLOBAL: userInfoPane.html]
thassman
  • Enthusiast

  • 63 posts
  • Corona SDK

So now we can use 2795 to upload to itunes connect, i have done that and all seems good.

Installing on the Apple TV with testflight works fine, but when launching the app it crashes immediately.

 

i get these 4 lines of errors, no lua errors or any print output  or anything that suggest that it actually executes main.lua

 

Dec 21 20:08:20 Apple-TV com.apple.xpc.launchd[1] (UIKitApplication:com.thasmobi.platform01[0x477f][163]) <Warning>: Service exited with abnormal code: 1
Dec 21 20:08:20 Apple-TV PineBoard[46] <Warning>: Application 'UIKitApplication:com.thasmobi.platform01[0x477f]' exited voluntarily.
Dec 21 20:08:20 Apple-TV UserEventAgent[23] <Warning>: 36752822178: id=com.thasmobi.platform01 pid=163, state=0
Dec 21 20:08:20 Apple-TV PineBoard[46] <Notice>: #T:[0x16e087000] #Notice #SYSTEM : PBServiceProviderRegistry: clearing endpoints {com.thasmobi.platform01} 
 

Note that the app works just fine, when build with a development provisioning profile and installed by cable with the "devices" xcode window.

 



[TOPIC: post.html]
#2

thassman

[GLOBAL: userInfoPane.html]
thassman
  • Enthusiast

  • 63 posts
  • Corona SDK

Anyone can hint if it works for you to install on tvOS via testflight?

I would be nice to know if it is something i my end, that needs to be fixed :)



[TOPIC: post.html]
#3

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,527 posts
  • Enterprise

Can you put a print statement in as the very first line in main.lua to make sure you're getting in or exiting before we start?

 

Thanks

Rob



[TOPIC: post.html]
#4

thassman

[GLOBAL: userInfoPane.html]
thassman
  • Enthusiast

  • 63 posts
  • Corona SDK

I already did that, and im not getting in, there is no lua printouts

 

Cheers



[TOPIC: post.html]
#5

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,527 posts
  • Enterprise

Engineering is on this!

 

Rob



[TOPIC: post.html]
#6

thassman

[GLOBAL: userInfoPane.html]
thassman
  • Enthusiast

  • 63 posts
  • Corona SDK

Just wanted to let you know that 2799 fixed this issue :)

 

Cheers,

Tommy



[TOPIC: post.html]
#7

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,527 posts
  • Enterprise


[topic_controls]
 
[/topic_controls]