Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Linking error - fuse
Started by prographodeveloper Oct 28 2015 12:21 PM

4 replies to this topic
fuse powered ad rally fuse linking
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

prographodeveloper

[GLOBAL: userInfoPane.html]
prographodeveloper
  • Contributor

  • 312 posts
  • Corona SDK

Fuse plugin seems to have problems - is causing linking error... but worked 4 days ago.

 

Any ideas?

 

Compiling Slices...

Compiling architecture: armv7
...
"/var/folders/kg/y8hhm3qn2fg_zypdvwdg39tw0000gn/T/CLtmpolD6Rs/armv7/xxx"</execute>
<result>duplicate symbol _llvm.cmdline in:
....app/.build/plugin.fuse/libplugin_fuse.a(FuseSDKReachability.o)
....app/.build/plugin.fuse/libplugin_fuse.a(FuseAdProviders.o)


[TOPIC: post.html]
#2

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 921 posts
  • Corona Staff

Hey! Thanks for letting us know about the issue. I'm afraid I don't get an error while trying to build app with fuse. May I ask to specify which Corona build and which Xcode are you using?

You can get Corona Simulator version in about menu and Xcode version with this command in terminal: xcodebuild -version



[TOPIC: post.html]
#3

prographodeveloper

[GLOBAL: userInfoPane.html]
prographodeveloper
  • Contributor

  • 312 posts
  • Corona SDK

Hey! Thanks for letting us know about the issue. I'm afraid I don't get an error while trying to build app with fuse. May I ask to specify which Corona build and which Xcode are you using?

You can get Corona Simulator version in about menu and Xcode version with this command in terminal: xcodebuild -version

 

 

Build: 2015.2728

 

xcodebuild -version

Xcode 6.4

Build version 6E35b

 

On the Corona build screen, under iOS SDK Version I select 8.4

 

Is that the right info?



[TOPIC: post.html]
#4

vlads

[GLOBAL: userInfoPane.html]
vlads
  • Contributor

  • 921 posts
  • Corona Staff

Yes, This info looks correct. I wasn't able to reproduce issue you having exactly, but my best guess that you're using outdated xcode and little oder version of Corona SDK. Try updating both.



[TOPIC: post.html]
#5

prographodeveloper

[GLOBAL: userInfoPane.html]
prographodeveloper
  • Contributor

  • 312 posts
  • Corona SDK

it works on xcode 7.1 / iOS sdk 9.1




[topic_controls]
[/topic_controls]