Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Problem with new Corona Build
Started by facuala Nov 21 2014 11:04 AM

- - - - -
11 replies to this topic

Best Answer Perry Clarke , 02 December 2014 - 10:57 AM

It should say:

XML-RPC server accepts POST requests only.

which indicates your copy of Windows can successfully connect to the internet.  The main thing that changed since the last release is that we now use HTTPS to connect to Corona's servers instead of HTTP.  Every computer should be able to connect via HTTPS and the fact that yours cannot indicates a configuration issue or possibly some kind of firewall or potentially even some kind of corruption.  Note that some browsers (e.g. Chrome) make their own arrangements to connect to the internet and do not use Windows' networking which is what is required for many applications.

 

Once you've fixed Internet Explorer, builds should work in CoronaSDK.

[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

facuala

[GLOBAL: userInfoPane.html]
facuala
  • Observer

  • 16 posts
  • Corona SDK

Hi, people! Sorry if this isn't the correct section. But today I installed the new public build (18 nobember) and when I tried to make a build of my game it show the message "Could not connect to the server. Please check your internet connection".

 

Can anybody help me?

Thanks!



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,925 posts
  • Enterprise

Well that error message is pretty straight forward.  There could have been some outage between our servers and you.  You could be running through a proxy or a firewall may be trying to block ports.  There shouldn't be any different network requirements between 2393a and 2511.  If you can install the older version does it also work?

 

Have you tried recently with the new version?

 

Rob



[TOPIC: post.html]
#3

facuala

[GLOBAL: userInfoPane.html]
facuala
  • Observer

  • 16 posts
  • Corona SDK

Sorry for my delay. I did't change anything since last version, but it doesn't work. I've already tried disabling the firewall, but nothing changes.

 

I have in my computer the older public release, if I uninstall the newest and install the older "CoronaSDK-2014.2381.msi", the compiler (builder) works correctly again.

 

I am puzzled and worried. I have Windows XP.

 

Debugger console says "WebServices: Call system.connect failed in (number) seconds: [HttpSendRequest]

A connection with the server could not be established"

 

Any ideas?



[TOPIC: post.html]
#4

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,925 posts
  • Enterprise

Can you try to build with the 2393 build?  it should be available from the download page under the archived versions.

 

Rob



[TOPIC: post.html]
#5

facuala

[GLOBAL: userInfoPane.html]
facuala
  • Observer

  • 16 posts
  • Corona SDK

Yes, I can build with that version. :/



[TOPIC: post.html]
#6

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

What happens if you go to https://developer.coronalabs.com/services/xmlrpc in Internet Explorer?



[TOPIC: post.html]
#7

facuala

[GLOBAL: userInfoPane.html]
facuala
  • Observer

  • 16 posts
  • Corona SDK

What happens if you go to https://developer.coronalabs.com/services/xmlrpc in Internet Explorer?

 

It shows "Internet Explorer can't show the Website" :/



[TOPIC: post.html]
#8

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

  Best Answer

It should say:

XML-RPC server accepts POST requests only.

which indicates your copy of Windows can successfully connect to the internet.  The main thing that changed since the last release is that we now use HTTPS to connect to Corona's servers instead of HTTP.  Every computer should be able to connect via HTTPS and the fact that yours cannot indicates a configuration issue or possibly some kind of firewall or potentially even some kind of corruption.  Note that some browsers (e.g. Chrome) make their own arrangements to connect to the internet and do not use Windows' networking which is what is required for many applications.

 

Once you've fixed Internet Explorer, builds should work in CoronaSDK.



[TOPIC: post.html]
#9

facuala

[GLOBAL: userInfoPane.html]
facuala
  • Observer

  • 16 posts
  • Corona SDK

Yes, I had to check de TSL protocol in the Internet Explorer to make it work.

Thanks for your support!



[TOPIC: post.html]
#10

michalzagrodzki

[GLOBAL: userInfoPane.html]
michalzagrodzki
  • Observer

  • 1 posts
  • Corona SDK

Perry, thank you for your answer. It really helped! 

 

To clear some things and give simple solution:

If you encounter error "Could not connect to server." on login in Corona SDK you should open Internet Explorer, go to Tools, then 'Internet Options', and then click tab 'Advanced'. Scroll down untill you see: "Use TLS 1.0" and check it. Click 'ok', close IE and try to login again.



[TOPIC: post.html]
#11

vonncc123

[GLOBAL: userInfoPane.html]
vonncc123
  • Contributor

  • 236 posts
  • Corona SDK

How to this in Mac OS?



[TOPIC: post.html]
#12

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

This is generally a Windows (or more precisely, Internet Explorer) issue so it's unlikely to be the same thing in OS X.

 

What are your symptoms?

Can you post the console log from a build attempt?




[topic_controls]
[/topic_controls]