Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

how do I enter dataSource in loadTileSet(name, source, dataSource)
Started by cjc83486 Nov 04 2014 09:57 PM

1 reply to this topic
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

cjc83486

[GLOBAL: userInfoPane.html]
cjc83486
  • Enthusiast

  • 34 posts
  • Corona SDK

Hopefully someone who still uses this engine can tell me what format I put dataSource in.

 

I currently load my tile sets like this:

 

mte.loadTileSet("build", "images/build.png")

 

I thought that you could then use a .tsx file like such

 

mte.loadTileSet("build", "images/build.png","externalTileset/build.tsx")

 

any ideas?  I've tried picking apart the mte.lua file for answers but I can't seem to figure it out.



[TOPIC: post.html]
#2

happymongoose

[GLOBAL: userInfoPane.html]
happymongoose
  • Contributor

  • 357 posts
  • Corona SDK

Hi there,

 

I've had the same problem with this, and I think it's because loadTileSet is broken in the latest version of MTE (which is the version I'm using).

 

When I tried poking around mte.lua, I found that loadTileSet relies on a function called loadMap (which is defined after loadTileSet, so it crashes Corona).  I tried moving loadTileSet further up mte.lua, and found that loadTileSet calls a function called ParseXmlText, also defined after it is used.  So I tried moving that function back to the top of mte.lua, and it still didn't work, because it relies on variables that haven't been created yet either (I couldn't figure out what they did).

 

I'd be happy to be proved wrong on this...




[topic_controls]
[/topic_controls]