Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Missing or invalid signature - need help!
Started by charlieshew Oct 27 2014 05:10 PM

13 replies to this topic
apple ios missing invalid siganture not signed
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

charlieshew

[GLOBAL: userInfoPane.html]
charlieshew
  • Observer

  • 12 posts
  • Corona SDK

I have been trying to upload an app to the app store for days now and keep getting the error:

 

Dear developer,

We have discovered one or more issues with your recent delivery for "Xxxx Xxxx". To process your delivery, the following issues must be corrected:

Missing or invalid signature - The bundle 'com.xxxxxxxxx.xxxxxxxx' at bundle path 'Xxxxxxxx.app' is not signed using an Apple submission certificate.

Once these issues have been corrected, you can then redeliver the corrected binary.

Regards,

The App Store team

 

I have read all the possible fixes for this issue on the forums here and have tried everything over and over and I'm still getting this email back from Apple after uploading my build.

 

I'm using Yosemite, Xcode 6.1, Corona 2393a. I have done the CFBundleShortVersionString in the plist. Checked that all my files have proper naming. Etc.. Etc......

 

I have deleted and re-created my Certificates and Provisioning Profiles numerous times. Basically, I've tried everything and I'm still getting the error every time I upload a build.

 

Can someone please help me? I have about 20 builds up on the App store that say "Invalid Binary". My client is getting impatient. TIA

 

 



[TOPIC: post.html]
#2

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,471 posts
  • Enterprise

Can you post your build.settings, a screen shot of the build screen just before you punch the build button. Please don't mask or blur anything. I need to see what's in your fields.

 

Also are you 100% sure you're using a Distribution profile (for the store, not AdHoc)?

 

Do you have any folders named "Res". "Resources" or is there a file named Icon perhaps with a funny character at the end of it in the folder?

 

Are you sure you have no invalid key/certificates in your Keychain access?

 

Also a full copy/paste of the error would be useful.  It's okay to put in your com.xxxxxxx, masking that out with xxxxx,s makes it harder to diagnose.

 

Rob



[TOPIC: post.html]
#3

charlieshew

[GLOBAL: userInfoPane.html]
charlieshew
  • Observer

  • 12 posts
  • Corona SDK

Hi Rob,

 

Thank you for your help!

 

"Can you post your build.settings, a screen shot of the build screen just before you punch the build button. Please don't mask or blur anything. I need to see what's in your fields."

 

Here are my build.settings:

 

>>-- build.settings 

settings = 
     android  = 
     { 
        usesExpansionFile  = true, 
        usesPermissions  = 
        { 
             "android.permission.RECORD_AUDIO", 
             "android.permission.WRITE_EXTERNAL_STORAGE", 
             "android.permission.INTERNET", 
             "com.android.vending.CHECK_LICENSE", 
        }, 
     }, 
     orientation = 
     { 
         default = "portrait", 
         supported = { "portrait" } 
      }, 
 
      iphone =  
      {  
         plist=  
         {  
              UIApplicationExitsOnSuspend = false,  
              UIStatusBarHidden = true,  
              CFBundleIconFile="Icon.png",  
              CFBundleIconFiles = {  
                   "Icon.png",  
                   "Icon@2x.png",  
                   "Icon-72.png",  
                   "Icon-72@2x.png",  
                   "Icon-76.png",  
                   "Icon-76@2x.png",  
                   "Icon-120.png",  
                   "Icon-60.png",  
                   "Icon-60@2x.png",  
                   "Icon-Small-50@2x.png",  
                   "Icon-Small-50.png",  
                   "Icon-Small.png",  
                   "Icon-Small@2x.png",  
              },  
         },  
       },  
}
 
<<
 
Here are screen shots of my build screen:
 
Build_Settings_window_1.png
 
Build_Settings_window_2.png
Build_Settings_window_3.png
 
 
>"Also are you 100% sure you're using a Distribution profile (for the store, not AdHoc)?"
 
I have only created one provisioning profile for my system that is for the app store and not AdHoc.
 
>"Do you have any folders named "Res". "Resources" or is there a file named Icon perhaps with a funny character at the end of it in the folder?"
 
There are no folders named "Res" or "Resources" in the folder. The only files in the folder with the name "Icon" are PNG files that were created by Kwik.
 
>"Are you sure you have no invalid key/certificates in your Keychain access?"
 
Here are screenshots of my keychain keys/certificates:
 
keychain1.png
keychain2.png
keychain3.png
Here is a full paste of the error email I receive from Apple:
 
>>

Dear developer,

We have discovered one or more issues with your recent delivery for "Darn Baby". To process your delivery, the following issues must be corrected:

Missing or invalid signature - The bundle 'com.vitalartsproductions.darnbaby' at bundle path 'DarnBaby.app' is not signed using an Apple submission certificate.

Once these issues have been corrected, you can then redeliver the corrected binary.

Regards,

The App Store team

<<


[TOPIC: post.html]
#4

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,471 posts
  • Enterprise

I see two possible things.  Both your keys and certs have a little triangle by them.  Can you open up the triangles and look for old keys/certs hiding in there?

 

Secondly I see your developer and distribution certificates are using different names.  Is it possible your Xcode doesn't know about the 2nd developer account?

 

Rob



[TOPIC: post.html]
#5

charlieshew

[GLOBAL: userInfoPane.html]
charlieshew
  • Observer

  • 12 posts
  • Corona SDK

Here are the the triangles dropped down:

 

keychain4.pngkeychain5.pngAs for the different names, I have read on the net in several places that this can be a problem. However, I can't rename the way the different sections were setup at the Apple Developer site myself. Apple has to do it. I have sent them emails and talked to their support staff asking them to change the names to be the same and they don't seem to want to do it for me for some reason.

 

As you can see, the distribution certificate has our company name of Vital Arts Productions, Inc. (I've also read that special characters like commas and periods can be a problem) but when you drop down the triangle, it says "CHARLES E SHEW" and it calls it a DEV KEY rather than a distribution key.

 

How can I make Xcode aware of this difference? Or, how can I get the names to be the same? 



[TOPIC: post.html]
#6

Squadventure Games

[GLOBAL: userInfoPane.html]
Squadventure Games
  • Contributor

  • 104 posts
  • Corona SDK

This is likely caused due to using an Application Name with spaces in it. Corona is using an invalid character that looks like a space character, but it's not, and it's using it everywhere the name is copied to (like the resulting build's file name). Corona, please fix this. Have a look here:

 

http://forums.coronalabs.com/topic/51236-new-certificate-beta-entitlement/?p=271899



[TOPIC: post.html]
#7

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,471 posts
  • Enterprise

Good catch.  Try to build it without the space in the name.

 

Rob



[TOPIC: post.html]
#8

charlieshew

[GLOBAL: userInfoPane.html]
charlieshew
  • Observer

  • 12 posts
  • Corona SDK

I gave taking the space out in the Application Name in the build window a try. Still getting an email with:

 

>>

iTunes Store <itunesconnect@apple.com>
2:03 PM (11 minutes ago)
cleardot.gif
 
cleardot.gif
cleardot.gif
 

Dear developer,

We have discovered one or more issues with your recent delivery for "Darn Baby". To process your delivery, the following issues must be corrected:

Missing or invalid signature - The bundle 'com.vitalartsproductions.darnbaby' at bundle path 'DarnBaby.app' is not signed using an Apple submission certificate.

Once these issues have been corrected, you can then redeliver the corrected binary.

Regards,

The App Store team

<<

 

So, I'm still stuck. I'm still thinking that it has something to do with the way that my account is setup at Apple and the fact that my distribution certificate gets created with "Vital Arts Productions, Inc." instead of "CHARLES E SHEW" as the certificate name. Do you think this is the problem? Should it matter what the name at the top of the cert is even though when you look inside the key the name is correct?

 

The only way I can get Apple to help me is if I have the app built in Xcode. They won't support Corona at all. Can you steer me to how I can get a working version of my app from Corona into Xcode? I have tried building for the simulator but that doesn't seem to be working on my system. After I do the build for Xcode, Corona says "Opening in Xcode Simulator" but nothing happens.

 

I appreciate any help anyone can give me here as I have been struggling with this for 2 weeks now!



[TOPIC: post.html]
#9

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,471 posts
  • Enterprise

If you can build with Xcode you should be able to build with Corona SDK if it's a name problem. Rob

[TOPIC: post.html]
#10

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,471 posts
  • Enterprise

If you can build with Xcode you should be able to build with Corona SDK if it's a name problem. Rob

[TOPIC: post.html]
#11

charlieshew

[GLOBAL: userInfoPane.html]
charlieshew
  • Observer

  • 12 posts
  • Corona SDK

The reason I want to use Xcode is because when I get an Apple support person on the phone to help me with this, as soon as I mention Corona, they say "I'm sorry, we can't support 3rd party software". That's the reason I want to get my App build over to Xcode so that I can demonstrate what the problem is to Apple support so they will even consider doing something for me. Without everything being Apple from top to bottom, they won't give me the time of day.

 

So, can someone please tell me how I can get my project into Xcode so the Apple guys will talk to me? Thanks



[TOPIC: post.html]
#12

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,471 posts
  • Enterprise

You can't get your Corona SDK project into an Xcode project that you can build without using Corona Enterprise.  You can't do it with Corona SDK.   But what you can do is build a simple Xcode project that's not your Corona SDK project.  Maybe a simple Hello World Xcode sample.  Try to build it using the same provisioning profile, name, etc. that you're tying to build Corona SDK with and see if you can upload it?

 

Rob



[TOPIC: post.html]
#13

GP Animations

[GLOBAL: userInfoPane.html]
GP Animations
  • Enthusiast

  • 95 posts
  • Corona SDK

Charlie, did you ever get this figured out? I'm in the same boat with a Kwik app I made for a client. I can't get it to iTunesConnect via application loader.

 

http://forums.coronalabs.com/topic/53903-missing-or-invalid-signature-not-signed-using-an-apple-submission-ticket/



[TOPIC: post.html]
#14

charlieshew

[GLOBAL: userInfoPane.html]
charlieshew
  • Observer

  • 12 posts
  • Corona SDK

Hi GP,

No, I have still not resolved this issue. This has been months now that I haven't been able to publish my apps because of this issue. I see that you have started a new thread about it. I will keep an eye out on that thread to see if you can get it resolved. We should let each other know if either of us figures this out. It's VERY frustrating!!




[topic_controls]
[/topic_controls]