Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Error in simulator when GameCircle plugin is required
Started by Alan PlantPot Oct 24 2014 01:42 AM

1 reply to this topic
amazon gamecircle simulator
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

Alan PlantPot

[GLOBAL: userInfoPane.html]
Alan PlantPot
  • Contributor

  • 935 posts
  • Corona SDK

I have posted this in another topic, but think it should be in it's own topic:

 

The Game Circle plugin was working for us until just shortly (not sure exactly when it stopped). Now as soon as the plugin is required I get this error:
Runtime error
error loading module 'plugin_gamecircle' from file '/Users/alan/Library/Application Support/Corona/Simulator/Plugins/plugin_gamecircle.lua':
/Users/alan/Library/Application Support/Corona/Simulator/Plugins/plugin_gamecircle.lua:93: 'end' expected (to close 'function' at line 89) near '='
stack traceback:
[C]: ?
[C]: in function 'require'
?: in function 'require'
/Users/alan/QuizTix/main.lua:3247: in function </Users/alan/QuizTix/main.lua:3228>
?: in function <?:221>
 
If I look at the plugin code in my library folder, I can see there are 2 errors in it:
 
1. As the error message suggests, the "end" is missing from the GetLocalPlayerSpoof function.
 
2. lib.WhisperSync.DecrementAccumulatingNumber has a typo - the upper case "S" in WhisperSync should be a lower case "s"
 
Fixing both of these allows the simulator to function as normal. I presume a change has been pushed with a typo in it or something, is it possible to have this fixed asap? It does concern me that a typo that immediately causes the game to stop running in the simulator has been pushed, which would suggest to me it hasn't been tested and hasn't been investigated since I posted my original message 4 days ago.  
 
I'm willing to accept that perhaps something is going wrong at my end, but I don't see how given that I simply download the plugin through the simulator as I would with any other plugin, and the same typos are there every time.


[TOPIC: post.html]
#2

jesse_busch

[GLOBAL: userInfoPane.html]
jesse_busch
  • Observer

  • 9 posts
  • Enterprise

Hey, Alan. This is Jesse, one from the plugin's dev team. Yeah, some typos got pushed accidentally and I've been too busy to other things to swing back around to double check things. I just made a push that should fix the typos. Thanks for catching them!

Also, since I recognize the Quiz Tix logo, I think you'll be happy to see we did implement the SignedInListener function in the latest version. The initialization callback is still being considered and worked on. Like I said, I've got a lot else on my plate at the moment 




[topic_controls]
[/topic_controls]