Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Vungle ads do not initialise since build 2014.2429 - Error shows up in app
Started by heftyApps Sep 19 2014 12:25 PM

41 replies to this topic
vungle error bug corona build init initialise
[TOPIC CONTROLS]
Page 2 of 2 1 2
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#26

seanDp32

[GLOBAL: userInfoPane.html]
seanDp32
  • Contributor

  • 168 posts
  • Corona SDK

Hey, I don't think facebook is a plugin in build 23 yet the plugin only works with 24 build and up. Get rid of the Facebook plugin in your build settings, and in main.lua call facebook like this:

Facebook = require ("facebook")--library

The reason why is that on build 23,the Facebook api is still build in the core of corona.

Hope this help
Sean

[TOPIC: post.html]
#27

Krivvenz

[GLOBAL: userInfoPane.html]
Krivvenz
  • Enthusiast

  • 44 posts
  • Corona SDK

Hi Sean,

               That's how I originally had it setup before adding Facebook to the build settings in my previous post. It still produces the same errors. Its weird though as the Vungle ads will work quite alot of the time but its almost like its a certain ad that causes it to crash. The ads do display most of the time but the error is still in the log and eventually it does totally crash out.

 

Kind Regards,

 

Krivvenz.



[TOPIC: post.html]
#28

seanDp32

[GLOBAL: userInfoPane.html]
seanDp32
  • Contributor

  • 168 posts
  • Corona SDK

Hey Krivvenz, I don't really see what facebook have to do with vungle crashing your app though. However, I included the Google services plugin in my app last night and my app stop crashing. The vungle ads work fine. I am not so hundred percent sure why your app crash after you included the plugin.

Sean

[TOPIC: post.html]
#29

Krivvenz

[GLOBAL: userInfoPane.html]
Krivvenz
  • Enthusiast

  • 44 posts
  • Corona SDK

Something to do with a missing Google Ad ID in Corona. A few people said if you add the Facebook library it includes the ID but doesn't seem to be happening in my case on the build I'm using.



[TOPIC: post.html]
#30

Krivvenz

[GLOBAL: userInfoPane.html]
Krivvenz
  • Enthusiast

  • 44 posts
  • Corona SDK

Sean - Did you have to setup any sort of Game Services in the Google Developer Console?



[TOPIC: post.html]
#31

seanDp32

[GLOBAL: userInfoPane.html]
seanDp32
  • Contributor

  • 168 posts
  • Corona SDK

Hey
Yes I did my app work with the play store
Game services
Sean

[TOPIC: post.html]
#32

jordyn.chuhaloff

[GLOBAL: userInfoPane.html]
jordyn.chuhaloff
  • Enthusiast

  • 49 posts
  • Enterprise

Hi All,

 

The Vungle plugin should be fixed now! Turns out, it was actually the support lib that was missing, but it's back in there. You don't need to include FB, just use our regular docs, here: http://docs.coronalabs.com/daily/plugin/vungle/

 

Jordyn / Corona



[TOPIC: post.html]
#33

jordyn.chuhaloff

[GLOBAL: userInfoPane.html]
jordyn.chuhaloff
  • Enthusiast

  • 49 posts
  • Enterprise

Hi All,

 

The Vungle plugin should be fixed now! Turns out, it was actually the support lib that was missing, but it's back in there. You don't need to include FB, just use our regular docs, here: http://docs.coronalabs.com/daily/plugin/vungle/

 

Jordyn / Vungle



[TOPIC: post.html]
#34

dimd

[GLOBAL: userInfoPane.html]
dimd
  • Contributor

  • 100 posts
  • Corona SDK

Awesome, thanks Jordyn for the quick fix & update.



[TOPIC: post.html]
#35

Krivvenz

[GLOBAL: userInfoPane.html]
Krivvenz
  • Enthusiast

  • 44 posts
  • Corona SDK

I've just done a fresh build to test with and the log is still riddled with vungle errors:

 

 

E/GooglePlayServicesUtil(28172): The Google Play services resources were not found. Check your project configuration to ensure that the resources are included.

E/Parcel  (  861): Class not found when unmarshalling: com.vungle.publisher.c

E/Parcel  (  861): java.lang.ClassNotFoundException: com.vungle.publisher.c

E/Parcel  (  861):     at java.lang.Class.classForName(Native Method)

E/Parcel  (  861):     at java.lang.Class.forName(Class.java:251)

E/Parcel  (  861):     at java.lang.Class.forName(Class.java:216)

E/Parcel  (  861):     at android.os.Parcel.readParcelableCreator(Parcel.java:2133)

E/Parcel  (  861):     at android.os.Parcel.readParcelable(Parcel.java:2097)

E/Parcel  (  861):     at android.os.Parcel.readValue(Parcel.java:2013)

E/Parcel  (  861):     at android.os.Parcel.readArrayMapInternal(Parcel.java:2314)

E/Parcel  (  861):     at android.os.Bundle.unparcel(Bundle.java:249)

E/Parcel  (  861):     at android.os.Bundle.getString(Bundle.java:1118)

E/Parcel  (  861):     at android.content.Intent.getStringExtra(Intent.java:5128)

E/Parcel  (  861):     at com.android.server.am.ActivityStackSupervisor.startActivityLocked(ActivityStackSupervisor.java:1453)

E/Parcel  (  861):     at com.android.server.am.ActivityStackSupervisor.startActivityMayWait(ActivityStackSupervisor.java:1052)

E/Parcel  (  861):     at com.android.server.am.ActivityManagerService.startActivityAsUser(ActivityManagerService.java:4183)

E/Parcel  (  861):     at com.android.server.am.ActivityManagerService.startActivity(ActivityManagerService.java:4063)

E/Parcel  (  861):     at android.app.ActivityManagerNative.onTransact(ActivityManagerNative.java:159)

E/Parcel  (  861):     at com.android.server.am.ActivityManagerService.onTransact(ActivityManagerService.java:2650)

E/Parcel  (  861):     at android.os.Binder.execTransact(Binder.java:404)

E/Parcel  (  861):     at dalvik.system.NativeStart.run(Native Method)

E/Parcel  (  861): Caused by: java.lang.NoClassDefFoundError: com/vungle/publisher/c

E/Parcel  (  861):     ... 18 more

E/Parcel  (  861): Caused by: java.lang.ClassNotFoundException: Didn't find class "com.vungle.publisher.c" on path: DexPathList[[directory "."],nativeLibraryDirectories=[/vendor/lib, /system/lib]]

 

 

I haven't had it crash yet though but the issue was intermittent..... I can only assume all the above errors are not good though?



[TOPIC: post.html]
#36

Krivvenz

[GLOBAL: userInfoPane.html]
Krivvenz
  • Enthusiast

  • 44 posts
  • Corona SDK

This is what my settings file looks like for the record:

 

settings = {
    orientation =
    {
        default = "landscapeRight",
    },
    
    plugins =
    {
        ["CoronaProvider.ads.vungle"] =
        {
            publisherId = "com.vungle",
        },
        
        
        
        ["plugin.google.play.services"] =
        {
            publisherId = "com.coronalabs",
           -- supportedPlatforms = { android=true },
        },
    },      
    
    android = {
    
        usesPermissions = {
            "android.permission.INTERNET",
            "android.permission.WRITE_EXTERNAL_STORAGE",
            "android.permission.ACCESS_NETWORK_STATE",
        },
    },
}



[TOPIC: post.html]
#37

jordyn.chuhaloff

[GLOBAL: userInfoPane.html]
jordyn.chuhaloff
  • Enthusiast

  • 49 posts
  • Enterprise

Hmm, I'm not sure why you're seeing that error.. are you able to run my sample app, here: https://github.com/Vungle/vungle-resources/tree/master/Corona-resources/coronaSampleApp? I just did, and it works fine for me.

 

Are you using Proguard, or maybe an older version of Corona?

 

Jordyn / Vungle



[TOPIC: post.html]
#38

Krivvenz

[GLOBAL: userInfoPane.html]
Krivvenz
  • Enthusiast

  • 44 posts
  • Corona SDK

Hi Jordyn,

                I've just built your sample app and done some testing and the exact same error messages there.

 

I don't use Proguard.

I'm using the latest public Corona build - 2393.

 

Is someone able to build the test app on a higher build and write the adb logcat to a txt file, then search the file for vungle to see if the same errors appear?

 

I've not been able to crash the game with my limited testing but my stats don't look right... like I have lots of downloads and active sessions but not many ad views so I'm a bit concerned the game is still crashing. If it is then there is a chance its because of all these errors?



[TOPIC: post.html]
#39

cmontesino

[GLOBAL: userInfoPane.html]
cmontesino
  • Enthusiast

  • 93 posts
  • Corona SDK

So we need a new public build to use the Vungle plugin now :o , my project used to work but now it doesn't with the same code. I also get "The Google Play services resources were not found:unsure:



[TOPIC: post.html]
#40

jordyn.chuhaloff

[GLOBAL: userInfoPane.html]
jordyn.chuhaloff
  • Enthusiast

  • 49 posts
  • Enterprise

@Krivvenz- I just tested with that public build- 2393 and it works fine. I'm also getting that error message, but no crashes, so you can ignore the message. If you aren't seeing many views, you should email your Vungle account manager. They can give you ideas on placements and video options. If you don't know who yours is, email monetize@vungle.com

 

@Cmontesino- same thing- don't worry about the error message. What do you mean, your code doesn't work? Are you seeing videos? Crashes? 

 

Jordyn / Vungle



[TOPIC: post.html]
#41

cmontesino

[GLOBAL: userInfoPane.html]
cmontesino
  • Enthusiast

  • 93 posts
  • Corona SDK

@jordyn.chuhaloff, you're right it works on the public build 2393! Yay :)  my error was choosing "None" as "Target App Store" when building with Corona SDK. 

 

Now I still have a problem, I'm trying incentivized videos and I'm getting two adView (and two adEnd) events after watching a video:

 

 

From the terminal:

I/Corona  ( 8877): onSystemEVENT.type:applicationResume

I/Corona  ( 8877): event.type: adEnd

I/Corona  ( 8877): event.type: adView

I/Corona  ( 8877): event.type: adView

I/Corona  ( 8877): event.type: adEnd

 

causing me to reward twice for a single video view. This didn't happen before with the same code.



[TOPIC: post.html]
#42

jordyn.chuhaloff

[GLOBAL: userInfoPane.html]
jordyn.chuhaloff
  • Enthusiast

  • 49 posts
  • Enterprise

@cmontesino:

 

For the duplicate callback issue, we have a fix in version 3.2.2. The native version is live, and we will be pushing it to Corona this week. There's already another forum post for this, here: http://forums.coronalabs.com/topic/51378-calling-composergotoscene-in-vungle-callback-throws-error/#entry266474. Please check there, I will update it when we push :)

 

Jordyn /Vungle




[topic_controls]
Page 2 of 2 1 2
 
[/topic_controls]