Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Issues with graphicsCompatibility = 1
Started by beernathan May 07 2014 08:46 PM

- - - - -
30 replies to this topic

[TOPIC CONTROLS]
Page 2 of 2 1 2
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#26

beernathan

[GLOBAL: userInfoPane.html]
beernathan
  • Contributor

  • 357 posts
  • Corona SDK

Nope - my game had been in production for nearly a year with alpha=0 - I've never used isHitTestable. Perhaps the default for isHitTestable changed between G1.0 and G2.0.



[TOPIC: post.html]
#27

beernathan

[GLOBAL: userInfoPane.html]
beernathan
  • Contributor

  • 357 posts
  • Corona SDK

Ummm... just tried to test my latest build on iPad 1 and got a warning saying the build can't be installed on iOS earlier than 6.0 - is this true? Related to graphics 2.0?

 

Very disappointed if I have to drop iPad 1 compatibility :-(



[TOPIC: post.html]
#28

davidcondolora

[GLOBAL: userInfoPane.html]
davidcondolora
  • Contributor

  • 172 posts
  • Corona SDK

@beernathan: 2189 was the last public build to support iOS 5, unfortunately. iOS 6 became the minimum version with build 2381. I'm not sure if it was related to Graphics 2.0 or changes that Apple made.



[TOPIC: post.html]
#29

beernathan

[GLOBAL: userInfoPane.html]
beernathan
  • Contributor

  • 357 posts
  • Corona SDK

What a shame :-(

 

The final nail in the coffin of my iPad 1 - I guess we all need to move on at some point!



[TOPIC: post.html]
#30

davidcondolora

[GLOBAL: userInfoPane.html]
davidcondolora
  • Contributor

  • 172 posts
  • Corona SDK

@beernathan: You may still be able to successfully submit with build 2189, but I dunno. I too was a bit bummed; it was nice to be able to ship a game that even iPad 1 users could buy and play, and I had an iPad 1 through most of our development.



[TOPIC: post.html]
#31

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,393 posts
  • Enterprise

It's not a Graphics 2.0 issue.  We dropped support for iOS 5 because of all of the hacks we were having to do to support iOS native things like GameCenter, the Camera app, facebook, etc.  Anything that put up a portrait only dialog box would crash landscape only apps, so we were constantly having to hack around this iOS 5 issue. 

 

If Apple does like last time, they will start requiring all apps to be uploaded against the iOS 8 SDK probably in February.  When this happens, Apple will have officially killed off iOS 5. 

 

The build that still supports iOS 5 is built with a version of Xcode that Apple does not allow submissions from any more.

 

Rob




[topic_controls]
Page 2 of 2 1 2
 
[/topic_controls]