Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Admob plugin causes frame rate drop when the ad cycles
Started by spacewolf Mar 01 2014 03:01 PM

88 replies to this topic
admob performance bug plugin monetization frame rate drop ads
[TOPIC CONTROLS]
« Page 4 of 4 2 3 4
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#76

Ernest

[GLOBAL: userInfoPane.html]
Ernest
  • Contributor

  • 107 posts
  • Corona SDK

Anyone having problems on Android with the ads not popping up until the second banner?

 

I'm having problems with admob on android with the first banner not showing (even though it's reporting as shown), but not on iOS where I switch between iAds and AdMob

Noticed a large thread on the subject with Android developers in regard to the first banner not showing up

https://groups.google.com/forum/#!topic/google-admob-ads-sdk/avwVXvBt_sM

 

Guess I'm switching to v1 admob on Android and v2 on iOS



[TOPIC: post.html]
#77

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,697 posts
  • Enterprise

@Ernest, this is is a Google issue.  One of our community members found that if you're using Google Play game services and you've logged in (effectively logging in to their G+ social network) that you get the first ad.

 

Google is turning off V1 on August 1st.  I've also heard that once you upgrade your AdMob dashboard, you also then have to use V2 as well.  I've not verified that.

 

Rob



[TOPIC: post.html]
#78

Ernest

[GLOBAL: userInfoPane.html]
Ernest
  • Contributor

  • 107 posts
  • Corona SDK

Well I'm not adding Google play services, but this problem does sound like a common issue in the Android community and there seems to be a work around that your developers should look into (it may also resolve your admob performance issue)

 

From the same link I provided above https://groups.google.com/forum/#!topic/google-admob-ads-sdk/avwVXvBt_sM

 

can you please get this to whomever implemented the admob v2 plugin

 

 

 

David Lott 
Feb 3

I was having this trouble as well and found a work-around.

First thing is don't add the ad to your layout initially!  I created an AdListener() and set it to my ad view.  Then in onAdLoaded, I put the ad view into my layout at that point.  You have to take care to only add the ad view once, and not every time an ad is loaded of course!  But this seems to make sure the ad is displayed the first time it is loaded, and not skipped.

Here is an example:

adView.setAdListener(new AdListener()
     {
      @Override
      public void onAdLoaded()
      {
       if(firstTime)
       {
        firstTime = false;
        layout.addView(adView);
       }
      }
     });


[TOPIC: post.html]
#79

MAS1

[GLOBAL: userInfoPane.html]
MAS1
  • Contributor

  • 279 posts
  • Corona SDK

@Ernest

 

This is, IMHO, quite a serious problem (always is if you're on the end of it!).

 

This bug was reported here:

http://forums.coronalabs.com/topic/47222-admob-v2-plugin-test-results/page-2?hl=+ingemar%20+bug%20+admob

 

 

I've reported bug (3) First banner not shown.

Case 32594

 

Note: This only happens on Android. 

iOS is OK.

 

It's been just over a month now since this bug was reported.

 

It's quite serious because if you call ads.hide() followed by ads.show() you are then waiting another 30 seconds (or whatever is set in the AdMob portal) before a new banner appears. That's bad.

 

I've had to resort to showing banners on the start screen in order to keep calls to ads.show() to a minimum. Don't like to show banners on the start screen but needs must...

 

I've just recently renewed my Pro subscription at the grandfathered in rate. At the top subscription rate I'm not so sure I would have renewed. All SDKs have their bugs but I can't help but think that Corona are prioritizing new features to the detriment of existing developers' outstanding bugs. I appreciate that all SDKs have bugs, but ... too many here for my liking.

 

Just mmy 2c/1p worth.



[TOPIC: post.html]
#80

davebollinger

[GLOBAL: userInfoPane.html]
davebollinger
  • Corona Geek

  • 1,373 posts
  • Corona SDK

is any work occurring on this?

 

i'm aware of two issues w admob, each of which individually make it nearly useless, and together make it completely useless: the first ad doesn't appear, and frame rate drops.

 

suggest engineering fully read: (as previously posted by Ernest above)

https://groups.google.com/forum/#!topic/google-admob-ads-sdk/avwVXvBt_sM

to see if it offers any hints

 

that thread, and others elsewhere, strongly suggest that it is a "layout issue", where/when the admob view is overlaid on top of an opengl surface view (instead of nestled beside it, as would be possible with a native android java app - where the problem doesn't seem to occur)

 

is it not also possible that some interplay between the adview overlaying the opengl surface is also responsible for the performance problems?  (perhaps somehow interfering with opengl redraws or something?)  i obviously have no clue, but just as food for thought

 

suggested workarounds for the first-ad-not-visible include making the ad view background transparent and/or altering how/when visible/invisible vs remove/re-add the view.  Q:  if upon fixing THAT problem, has the frame-rate issue been affected as well?

 

in any case, the implications of that thread, along with reports elsewhere of ppl with native java who DON'T see either problem with "proper" layouts, are that the problem mignt not be on google's/admob's end, but rather resulting from older layout strategies that are no longer appropriate.

 

worth an engineering look?



[TOPIC: post.html]
#81

dchan

[GLOBAL: userInfoPane.html]
dchan
  • Contributor

  • 360 posts
  • Corona Staff

The admob-v2 plugin has been updated so that the first ad is shown correctly.  Please report if you see otherwise.

@Ernest That was a very helpful thread, thank you.



[TOPIC: post.html]
#82

ubj3d.android

[GLOBAL: userInfoPane.html]
ubj3d.android
  • Contributor

  • 741 posts
  • Corona SDK

The admob-v2 plugin has been updated so that the first ad is shown correctly.  Please report if you see otherwise.
@Ernest That was a very helpful thread, thank you.


This is really great news!

Now make us ueber happy by solving the FPS drop problem, please...

[TOPIC: post.html]
#83

ubj3d.android

[GLOBAL: userInfoPane.html]
ubj3d.android
  • Contributor

  • 741 posts
  • Corona SDK

New bug which causes app crash!

 

The first ad is now shown but when I try to show an interstitial after the banner, the app crashes.

 

Here is the code at which it crashes:

 

ads.hide()

ads.show( INTERSTITIAL, { x=0, y=0, appId = ADMOB_FULL, testMode=false } )    
 

 

06-13 23:41:22.159: E/AndroidRuntime(11757): FATAL EXCEPTION: main
06-13 23:41:22.159: E/AndroidRuntime(11757): java.lang.NullPointerException
06-13 23:41:22.159: E/AndroidRuntime(11757):     at CoronaProvider.ads.admob.AdMobAd$2.run(AdMobAd.java:155)
06-13 23:41:22.159: E/AndroidRuntime(11757):     at android.os.Handler.handleCallback(Handler.java:615)
06-13 23:41:22.159: E/AndroidRuntime(11757):     at android.os.Handler.dispatchMessage(Handler.java:92)
06-13 23:41:22.159: E/AndroidRuntime(11757):     at android.os.Looper.loop(Looper.java:137)
06-13 23:41:22.159: E/AndroidRuntime(11757):     at android.app.ActivityThread.main(ActivityThread.java:4895)
06-13 23:41:22.159: E/AndroidRuntime(11757):     at java.lang.reflect.Method.invokeNative(Native Method)
06-13 23:41:22.159: E/AndroidRuntime(11757):     at java.lang.reflect.Method.invoke(Method.java:511)
06-13 23:41:22.159: E/AndroidRuntime(11757):     at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:994)
06-13 23:41:22.159: E/AndroidRuntime(11757):     at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:761)
06-13 23:41:22.159: E/AndroidRuntime(11757):     at dalvik.system.NativeStart.main(Native Method)
06-13 23:41:22.214: E/android.os.Debug(329): !@Dumpstate > dumpstate -k -t -z -d -o /data/log/dumpstate_app_error



[TOPIC: post.html]
#84

dchan

[GLOBAL: userInfoPane.html]
dchan
  • Contributor

  • 360 posts
  • Corona Staff

You can get around that by calling http://docs.coronalabs.com/daily/plugin/ads-admob-v2/load.html for now.  This crash will be fixed shortly.



[TOPIC: post.html]
#85

ubj3d.android

[GLOBAL: userInfoPane.html]
ubj3d.android
  • Contributor

  • 741 posts
  • Corona SDK

You can get around that by calling http://docs.coronalabs.com/daily/plugin/ads-admob-v2/load.html for now.  This crash will be fixed shortly.

 

It is OK now, thank you very much.

 

So back to the thread topic: Admob plugin causes frame rate drop

 

This is really a business killer.

E.g. In our games we have a dynamic interface (nothing to fancy, the buttons zoom in-out) and when the banners are on you can see stuttering. Of course it is even worse when the objects and animations inside the gameplay start to stutter.

 

Now, once again I have adMob plugin integrated in my Java written game "Ultimate BlackJack 3D", please download it and you will see there is no stuttering at all.

 

Also, I can't find nowhere on the net people with other tools (e.g. Unity) reporting such behavior.

 

 

Corona Labs, please take another look into this big issue.

 

Regards,

Damir.

 

P.S. Gremlin Interactive if you are reading this, please consider making your version of the adMob plugin, I am sure if implemented right, you would have many customers.



[TOPIC: post.html]
#86

spacewolf

[GLOBAL: userInfoPane.html]
spacewolf
  • Contributor

  • 298 posts
  • Enterprise

It's been 3 and 1/2 months so far since I first reported this issue to Corona and have yet to see a serious response from them... 



[TOPIC: post.html]
#87

dchan

[GLOBAL: userInfoPane.html]
dchan
  • Contributor

  • 360 posts
  • Corona Staff

[TOPIC: post.html]
#88

ubj3d.android

[GLOBAL: userInfoPane.html]
ubj3d.android
  • Contributor

  • 741 posts
  • Corona SDK

Seems the animated AdSense ads are causing the FPS drop.

 

Is there a way to turn them off in AdMob dashboard ? (can't find it)



[TOPIC: post.html]
#89

tomekgt

[GLOBAL: userInfoPane.html]
tomekgt
  • Enthusiast

  • 47 posts
  • Enterprise

Seems the animated AdSense ads are causing the FPS drop.

 

Is there a way to turn them off in AdMob dashboard ? (can't find it)

 

This is such a google thing to do. Just like their failure to allow permanent settings on maps to avoid toll ways. 

Instead of allowing us to disable animated ads, they are basically just saying, 'You're using it wrong'.




[topic_controls]
« Page 4 of 4 2 3 4
 
[/topic_controls]