Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Debugging "attempt to call a table value"
Started by beernathan Jan 29 2014 04:49 PM

- - - - -
3 replies to this topic
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

beernathan

[GLOBAL: userInfoPane.html]
beernathan
  • Contributor

  • 357 posts
  • Corona SDK

Hi,

 

I'm getting this error reported frequently enough for it to be a worry (through my game analytics)

 

"?:-1: attempt to call a table value stack traceback:"

 

Looks like I'm passing a table instead of a value somewhere, but where? Any idea of how I could go about debugging this?

 

Thanks,

Nathan.



[TOPIC: post.html]
#2

primoz.cerar

[GLOBAL: userInfoPane.html]
primoz.cerar
  • Contributor

  • 455 posts
  • Corona SDK

Actually as it seems from the error you are passing a value where you should be passing a function. Maybe a call back function?



[TOPIC: post.html]
#3

beernathan

[GLOBAL: userInfoPane.html]
beernathan
  • Contributor

  • 357 posts
  • Corona SDK

Hmmm - not sure how that could happen. I'll have a sniff around.

 

There are a stack of errors I'm getting like there where there is no line or function reference (see one below). Any idea how I can get more detail?

 

 

 ?:0: attempt to index field '?' (a nil value) stack traceback: [C]: ? ?: in function <?:1778> ?: in function <?:218>
 


[TOPIC: post.html]
#4

primoz.cerar

[GLOBAL: userInfoPane.html]
primoz.cerar
  • Contributor

  • 455 posts
  • Corona SDK

No function name in stack trace means that the error occured in a compiled library not in your source.

As to why I can only speculate but it could be a simple problem in your code passing something wrong to the library.




[topic_controls]
[/topic_controls]