Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

2014.2123: Getting deprecated warning message
Started by richard9 Jan 08 2014 11:40 AM

12 replies to this topic

Best Answer richard9 , 15 January 2014 - 09:02 AM

Warning Message fixed: 2104.2135

[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

richard9

[GLOBAL: userInfoPane.html]
richard9
  • Corona Geek

  • 1,118 posts
  • Enterprise

Just a FYI to the team; the fix listed on 2119 for enterprise:

 

  • Enterprise: Deprecate CoronaRuntimeDispatchEvent(). Instead use CoronaDispatchRuntimeEvent(). This will automatically pop the event off the top of the stack which is consistent with how CoronaDispatchEvent works as well as with other Lua APIs that similarly pop objects off the top of the stack.

 

Is visible on the pro (ie: regular daily build) 2014.2123 as a warning message:

 

[Lua::RuntimeDispatchEvent()] WARNING: This function is deprecated. Use Lua::DispatchRuntimeEvent() instead.

 



[TOPIC: post.html]
#2

walter

[GLOBAL: userInfoPane.html]
walter
  • Moderator

  • 726 posts
  • Alumni

Ah, good catch Richard. We'll look into it.



[TOPIC: post.html]
#3

walter

[GLOBAL: userInfoPane.html]
walter
  • Moderator

  • 726 posts
  • Alumni

BTW, in what situation do you see this? Simulator or device?

 

I ran a few quick samples on the Mac Simulator and don't see this message on the console.



[TOPIC: post.html]
#4

richard9

[GLOBAL: userInfoPane.html]
richard9
  • Corona Geek

  • 1,118 posts
  • Enterprise

Seeing it specifically on OSX.

 

Daily Build: 2014.2123

OSX: 10.9 Mavericks

 

I think you may have to actually rig together some code to see it though, like an enterFrame listener...



[TOPIC: post.html]
#5

walter

[GLOBAL: userInfoPane.html]
walter
  • Moderator

  • 726 posts
  • Alumni

What triggers it? 

 

If I run a few samples (E.g. fishies), I don't see the message.



[TOPIC: post.html]
#6

richard9

[GLOBAL: userInfoPane.html]
richard9
  • Corona Geek

  • 1,118 posts
  • Enterprise

Strangely enough, the best way to trigger it is to break your code.

 

--local group = display.newGroup()
local box = display.newRect(0,0,32,32)
group:insert(box)

 

This triggers the message. Uncommenting line 1 will ensure the message does not appear.



[TOPIC: post.html]
#7

mpappas

[GLOBAL: userInfoPane.html]
mpappas
  • Contributor

  • 527 posts
  • Enterprise

I'm getting this same error on build 2126, on AN OLD Droid. 2126 seems to work when I build using enterprise for ios, but when I build using the simulator for android (only), My app shows a blank/black screen and stops, sort of... Input events seem to fire off for the objects that should be there, but the display system seems to have lost a buffer/crapped out after that dispatchRuntimeEvent error...  Perhaps related to Walters query, the app loses it shortly after startup, but not until it enters the main ui code where it does install an enterFrame handler. It also looks like the enterFrame isn't being called, on first glance...

 

The app also reports it got a suspend/resume for a system notification event after the above DispatchRuntimeEvent error (so I guess that event still worked...)



[TOPIC: post.html]
#8

thegdog

[GLOBAL: userInfoPane.html]
thegdog
  • Contributor

  • 564 posts
  • Corona SDK

Might be something totally different, but there is a known issue with Graphics 2.0 and Android devices with the Tegra 2 chipset.  Nothing displays on the screen.  This happens with the sample apps too. 

 

Documented here:

http://forums.coronalabs.com/topic/42581-black-screen-loading-hello-world-sample-app-on-android-20132099/

 

Just wanted to point that out in case you didn't know about it and you might be trying to hunt down something unrelated.



[TOPIC: post.html]
#9

mpappas

[GLOBAL: userInfoPane.html]
mpappas
  • Contributor

  • 527 posts
  • Enterprise

ok, just installed simulator v2130, and some progress on my old droid. It reports "NVidia Tegra" (along with "MB860 / Arm / 2.3.6 / OpenGL ES 2.0" )

 

The first / main screen shows up now, yay! However, a lot of my text is instead just a solid white rectangle (instead of white on transparent, for example). So my screen is covered now with mostly white rectangles and a few text strings that show up correctly. Didn't see any differences in the display.newText calls between them. If I notice some discrepancy, I'll update here...



[TOPIC: post.html]
#10

thegdog

[GLOBAL: userInfoPane.html]
thegdog
  • Contributor

  • 564 posts
  • Corona SDK

Brent from Corona apparently told another developer that they had gotten some of the Tegra 2 issues resolved, though not sure where he said that, but there has been no update in the main thread so I believe they are still working on it.



[TOPIC: post.html]
#11

walter

[GLOBAL: userInfoPane.html]
walter
  • Moderator

  • 726 posts
  • Alumni

@mppapas, @thegdog, the black screen issues on Android are a separate issue and we have a fix on the way.

 

Let's keep this thread on the deprecated warning log message --- it's confirmed to occur when a Lua syntax error handling in the Simulator. This will be fixed in the daily build 2132 or above. 



[TOPIC: post.html]
#12

thegdog

[GLOBAL: userInfoPane.html]
thegdog
  • Contributor

  • 564 posts
  • Corona SDK

walter,

I do know the deprecated warning is separate.  I was just pointing out that he now mentioned the blank screen, which sounded like something different from the deprecated warning, and was just directing him over to that, in case that is what he was experiencing.



[TOPIC: post.html]
#13

richard9

[GLOBAL: userInfoPane.html]
richard9
  • Corona Geek

  • 1,118 posts
  • Enterprise

  Best Answer

Warning Message fixed: 2104.2135




[topic_controls]
[/topic_controls]