Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

is display.save broken on G2.0?
Started by rune7 Jan 06 2014 08:44 AM

16 replies to this topic
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

rune7

[GLOBAL: userInfoPane.html]
rune7
  • Contributor

  • 363 posts
  • Corona SDK

I've moved one of my projects to the new graphics, but I'm unable to make the display.save() to work. It crashes the simulator.

I've tried taking the sample code from the api docs and that code also crashes the simulator.

 

has anyone noted this issue? is there something new instead?

running on build 2114



[TOPIC: post.html]
#2

bjsorrentino

[GLOBAL: userInfoPane.html]
bjsorrentino
  • Veteran

  • 8,506 posts
  • Corona SDK

Hi @rune7,

Let me check into this. When you cite the code from the docs, do you mean this page? If so, which of the two examples?

 

http://docs.coronalabs.com/api/library/display/save.html

 

Thanks,

Brent



[TOPIC: post.html]
#3

rune7

[GLOBAL: userInfoPane.html]
rune7
  • Contributor

  • 363 posts
  • Corona SDK

Thanks. I refer to the first example, the full resolution one.

the legacy version doesn't work as well, as it was the version I had before the transition to G2.0



[TOPIC: post.html]
#4

bjsorrentino

[GLOBAL: userInfoPane.html]
bjsorrentino
  • Veteran

  • 8,506 posts
  • Corona SDK

Hi @rune7,

I tested the example using Build #2121, on OS X, and it works fine. What environment are you testing on?

 

Brent



[TOPIC: post.html]
#5

rune7

[GLOBAL: userInfoPane.html]
rune7
  • Contributor

  • 363 posts
  • Corona SDK

windows simulator.



[TOPIC: post.html]
#6

bjsorrentino

[GLOBAL: userInfoPane.html]
bjsorrentino
  • Veteran

  • 8,506 posts
  • Corona SDK

Hi @rune7,

Does the same thing happen in the most recent daily build? If so, let me report this the engineering to be investigated.

 

Brent



[TOPIC: post.html]
#7

rune7

[GLOBAL: userInfoPane.html]
rune7
  • Contributor

  • 363 posts
  • Corona SDK

Yes, Just tested it on latest build (2123) and win simulator still freezes when calling display.save()



[TOPIC: post.html]
#8

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

I've modified the sample in Samples/Storage/ScreenCaptureToFile to match the sample code in the docs and it works fine for me.  Does that sample work for you?

 

Can you post the code that is crashing for you?



[TOPIC: post.html]
#9

RedBeach

[GLOBAL: userInfoPane.html]
RedBeach
  • Corona Geek

  • 1,132 posts
  • Corona SDK

No problems here...

 

Just saw a post from a guy that was having a problem that the image was disappearing after saving if but nothing that crashes the simulator/app



[TOPIC: post.html]
#10

rune7

[GLOBAL: userInfoPane.html]
rune7
  • Contributor

  • 363 posts
  • Corona SDK

I've just tested Samples/Storage/ScreenCaptureToFile on my windows machine, build 2123, and it crashes too! 

I have two installations of corona on two folders - one for legacy (build 1260) and one for the new G2.0. could this be an issue???



[TOPIC: post.html]
#11

rune7

[GLOBAL: userInfoPane.html]
rune7
  • Contributor

  • 363 posts
  • Corona SDK

Corona, are you able to reproduce this issue using your ScreenCaptureToFile project???

this is blocking my work.

 

I've opened a bug. Lets hope for better response time than last time.



[TOPIC: post.html]
#12

bjsorrentino

[GLOBAL: userInfoPane.html]
bjsorrentino
  • Veteran

  • 8,506 posts
  • Corona SDK

Hi @rune7,

We can't reproduce this on our side. Does the Corona console window (the thing that looks like a DOS box) provide some kind of clue to what's happening on your side?

 

Best regards,

Brent



[TOPIC: post.html]
#13

rune7

[GLOBAL: userInfoPane.html]
rune7
  • Contributor

  • 363 posts
  • Corona SDK

I'm afraid not.

There must be some dll or something missing/wrong version in my windows installation that your new G.2 libraries depend on. on mac this works fine. problem is, I develop only on windows and depend heavily on the simulator.

I've removed all previous installations and reinstalled the latest build with no luck.

another thing that freezes is creating a snapshot object - display.newSnapshot. I've tried using your TrailingPaint sample and it crashes the simulator too.



[TOPIC: post.html]
#14

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

Can you post a screenshot of your screen when the Simulator has crashed?  It's a longshot but sometimes we see something that helps.  Make sure the Corona Simulator console is visible in the screenshot as well as the operating system error dialog.



[TOPIC: post.html]
#15

rune7

[GLOBAL: userInfoPane.html]
rune7
  • Contributor

  • 363 posts
  • Corona SDK

I can't add images from my machine here. I can send it to your mail if you provide me one.



[TOPIC: post.html]
#16

Perry Clarke

[GLOBAL: userInfoPane.html]
Perry Clarke
  • Moderator

  • 850 posts
  • Corona Staff

Send it to support@coronalabs.com



[TOPIC: post.html]
#17

rune7

[GLOBAL: userInfoPane.html]
rune7
  • Contributor

  • 363 posts
  • Corona SDK

Just tested version 2148. problem still happens on dev machine.

However, I also tested on another windows PC and the problem does not appear there. its clearly a machine specific issue. however, i have no idea what might cause this thing and I can't switch machines.

 

I've tried to un install all corona stuff and went through the registry as well. however, problem persists. 

It did not happen when using pre- Graphics 2.0 builds.

 

Can you think of some missing/old library or dll i might need to update for G2.0 to work properly?




[topic_controls]
[/topic_controls]