Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Problem with TableView:scrollToIndex()
Started by rodrigo.chapuis Nov 17 2013 11:59 AM

12 replies to this topic
tableview scrolltoindex widgets graphics 2.0
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

rodrigo.chapuis

[GLOBAL: userInfoPane.html]
rodrigo.chapuis
  • Observer

  • 22 posts
  • Corona SDK

Hi.

 

I am working on migrating my code to the new api, and found out some things that are not working for me.

I am having problems using the scrollToIndex of the tableview. Seems to me that is still not using the new center anchors.. because if you call scrollToIndex, the rows are being positioned from the center of the tableview. 

 

You can easily test this by opening the ListView1 sample code and add list:scrollToIndex(1,0) at the very end of main.lua file, after the for loop where the rows are inserted.

 

Any info about this? 

Also.. if this is fixed in daily builds.. where can the starter users get it ?

 

Thanks!



[TOPIC: post.html]
#2

ksan

[GLOBAL: userInfoPane.html]
ksan
  • Corona Geek

  • 2,795 posts
  • Corona SDK

Good catch. I also see the same on my end. Interesting thing though is when I use 0 for the time (optional) parameter as you mention the scrollToIndex does not work at all. Nothing happens. When I put in a value greater than 0, even 1 will do, then the scrollToIndex work and it works wrongly in the manner you describe again. So the time issue might be another bug in there. 



[TOPIC: post.html]
#3

rodrigo.chapuis

[GLOBAL: userInfoPane.html]
rodrigo.chapuis
  • Observer

  • 22 posts
  • Corona SDK

I have no problem using 0 as the time param. It scrolls fine, only that is offsetted by half the height.

[TOPIC: post.html]
#4

ksan

[GLOBAL: userInfoPane.html]
ksan
  • Corona Geek

  • 2,795 posts
  • Corona SDK

This is very interesting as we are both using the same sample to verify the initial bug that you discovered. I have no idea why we would see different behavior on the time delay parameter but 0 is definitely not working on this end. 2 bugs that need to be looked at then.



[TOPIC: post.html]
#5

bjsorrentino

[GLOBAL: userInfoPane.html]
bjsorrentino
  • Veteran

  • 8,506 posts
  • Corona SDK

I added this entry to the tracking spreadsheet, to be investigated. Thanks for the heads up.



[TOPIC: post.html]
#6

jonjonsson

[GLOBAL: userInfoPane.html]
jonjonsson
  • Corona Geek

  • 1,051 posts
  • Corona SDK

Sorry to hijack.

 

@Brent, not sure what tracking spreadsheet you are referring to but can you please check this and possibly add it? http://forums.coronalabs.com/topic/41488-tableview-layout-bug-when-having-defined-defaults-for-anchorx-and-anchory/

 

This bug is a stopper for me and anyone that decided to put top left as default anchor position and using a tableview.



[TOPIC: post.html]
#7

ksan

[GLOBAL: userInfoPane.html]
ksan
  • Corona Geek

  • 2,795 posts
  • Corona SDK

I think he is referring to my humble issues tracking spreadsheet. It can be found at : 

 

docs.google.com/spreadsheet/ccc?key=0AsuRVbWElS3YdGpCN0V3emtmWnlwQmRUOVlpb3RkOGc&usp=sharing

 

also the thread where this list was introduced is here : 

 

http://forums.coronalabs.com/topic/37217-list-of-open-widget-20-bugs-promised-features/page-3#

 

It offers great visibility to open issues. Kindly take a moment to enter your bug in there if you can. Thanks much!



[TOPIC: post.html]
#8

jonjonsson

[GLOBAL: userInfoPane.html]
jonjonsson
  • Corona Geek

  • 1,051 posts
  • Corona SDK

[TOPIC: post.html]
#9

ksan

[GLOBAL: userInfoPane.html]
ksan
  • Corona Geek

  • 2,795 posts
  • Corona SDK

Any luck in reproducing the issue? Hope to see a fix for this one soon. 



[TOPIC: post.html]
#10

alexf

[GLOBAL: userInfoPane.html]
alexf
  • Alumni

  • 253 posts
  • Corona SDK

Hey guys,

 

The fix for this will be available in a daily soon.

 

Thanks,

alex



[TOPIC: post.html]
#11

ksan

[GLOBAL: userInfoPane.html]
ksan
  • Corona Geek

  • 2,795 posts
  • Corona SDK

Super. Thanks for letting us know. This one was a show-stopper. 



[TOPIC: post.html]
#12

rodrigo.chapuis

[GLOBAL: userInfoPane.html]
rodrigo.chapuis
  • Observer

  • 22 posts
  • Corona SDK

Hi guys, 

 

any idea when this might be on the open source code for the widgets on github? Otherwise i will need to wait until the next public release for this fix.

 

Thanks



[TOPIC: post.html]
#13

ksan

[GLOBAL: userInfoPane.html]
ksan
  • Corona Geek

  • 2,795 posts
  • Corona SDK

I can confirm this is fixed as of 2013.2109. Maybe it was fixed earlier. Not sure. Moving to Fixed tab in the spreadsheet. Thanks much Alex!!!




[topic_controls]
[/topic_controls]