Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Black screen with 2013.2076 Public Build on Razr Maxx
Started by alexk413x Nov 14 2013 05:34 PM

12 replies to this topic
razr maxx black screen
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

alexk413x

[GLOBAL: userInfoPane.html]
alexk413x
  • Observer

  • 9 posts
  • Corona SDK

I updated my app the to work with the new release of corona today but when I install it on my Motorola Droid Razr Maxx with android 4.1.2 the app just gives me a black screen. This also happens with the default sample apps that come with corona as well.  I tested the anchor points sample app and the color of the background changed to grey but the arm image for the clock did not appear.  To me it seems that images are not being properly loaded on this device with this new build.  Is there any fixes for this? Or has anyone else had this issue with the update?



[TOPIC: post.html]
#2

Alex@Panc

[GLOBAL: userInfoPane.html]
Alex@Panc
  • Corona Geek

  • 1,731 posts
  • Corona SDK

Can you get the logcat and give us some error logs to look over?



[TOPIC: post.html]
#3

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,376 posts
  • Enterprise

If you need help getting the information from your device's logcat, please read this tutorial:

 

http://www.coronalabs.com/blog/2013/07/09/tutorial-basic-debugging/

 

We need to see what errors are happening under the hood.

 

Thanks

Rob



[TOPIC: post.html]
#4

andyh1

[GLOBAL: userInfoPane.html]
andyh1
  • Observer

  • 2 posts
  • Corona SDK

I ran into this same issue on my Moto Maxx running 4.2.2.  The line require ""CiderDebugger";" seems to be the issue in my case.  Here is the log from the HelloWorld sample code:

 

11-14 21:17:19.819 28419 28435 V Corona  : > Class.forName: network.LuaLoader

 

11-14 21:17:19.819 28419 28435 V Corona  : < Class.forName: network.LuaLoader

 

11-14 21:17:19.819 28419 28435 V Corona  : Loading via reflection: network.LuaLoader

 

11-14 21:17:19.850 28419 28435 V Corona  : > Class.forName: CoronaProvider.licensing.google.LuaLoader

 

11-14 21:17:19.850 28419 28435 V Corona  : < Class.forName: CoronaProvider.licensing.google.LuaLoader

 

11-14 21:17:19.855 28419 28435 V Corona  : Loading via reflection: CoronaProvider.licensing.google.LuaLoader

 

11-14 21:17:19.860 28419 28435 I Corona  : Runtime error

 

11-14 21:17:19.860 28419 28435 I Corona  : ...mpleCode/GettingStarted/HelloWorld/CiderDebugger.lua:476: attempt to index local 'udpSocket' (a nil value)

 

11-14 21:17:19.860 28419 28435 I Corona  : stack traceback:

 

11-14 21:17:19.860 28419 28435 I Corona  :     [C]: ?

 

11-14 21:17:19.860 28419 28435 I Corona  :     ...mpleCode/GettingStarted/HelloWorld/CiderDebugger.lua:476: in main chunk

 

11-14 21:17:19.860 28419 28435 I Corona  :     [C]: in function 'require'

 

11-14 21:17:19.860 28419 28435 I Corona  :     ?: in function 'require'

 

11-14 21:17:19.860 28419 28435 I Corona  :     ...onaSDK/SampleCode/GettingStarted/HelloWorld/main.lua:1: in main chunk

 

11-14 21:17:19.863 28419 28435 I Corona  : Runtime error

 

11-14 21:17:19.863 28419 28435 I Corona  : 

 

11-14 21:17:19.863 28419 28435 I Corona  : stack traceback:

 

11-14 21:17:19.863 28419 28435 I Corona  :     [C]: ?

 

11-14 21:17:19.863 28419 28435 I Corona  :     ...mpleCode/GettingStarted/HelloWorld/CiderDebugger.lua:476: in main chunk

 

11-14 21:17:19.863 28419 28435 I Corona  :     [C]: in function 'require'

 

11-14 21:17:19.863 28419 28435 I Corona  :     ?: in function 'require'

 

11-14 21:17:19.863 28419 28435 I Corona  :     ...onaSDK/SampleCode/GettingStarted/HelloWorld/main.lua:1: in main chunk



[TOPIC: post.html]
#5

jonjonsson

[GLOBAL: userInfoPane.html]
jonjonsson
  • Corona Geek

  • 1,051 posts
  • Corona SDK

Are you using Glider? When building you must use the Build button in Glider before then making your build in Corona or the debug ciderDebugger filer will be included in the project.



[TOPIC: post.html]
#6

andyh1

[GLOBAL: userInfoPane.html]
andyh1
  • Observer

  • 2 posts
  • Corona SDK

I am using Glider.  I will use the build button from now on.



[TOPIC: post.html]
#7

alexk413x

[GLOBAL: userInfoPane.html]
alexk413x
  • Observer

  • 9 posts
  • Corona SDK

C:\Program Files (x86)\Android\android-sdk\platform-tools>adb logcat Corona:v *:s
--------- beginning of /dev/log/system
--------- beginning of /dev/log/main
11-14 21:29:06.864  4054  4081 V Corona  : > Class.forName: network.LuaLoader
11-14 21:29:06.864  4054  4081 V Corona  : < Class.forName: network.LuaLoader
11-14 21:29:06.864  4054  4081 V Corona  : Loading via reflection: network.LuaLoader
11-14 21:29:08.067  4054  4081 V Corona  : > Class.forName: CoronaProvider.licensing.google.LuaLoader
11-14 21:29:08.067  4054  4081 V Corona  : < Class.forName: CoronaProvider.licensing.google.LuaLoader
11-14 21:29:08.099  4054  4081 V Corona  : Loading via reflection: CoronaProvider.licensing.google.LuaLoader

 

This is the log from AnchorPoints app running on my razr maxx with android 4.1.2.  I do not see any errors but i still do not see the clock hand image.



[TOPIC: post.html]
#8

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,376 posts
  • Enterprise

@alexk413x can you do that just doing "adb logcat" and leaving the other parts off.  There may be errors not generated by the Corona activity that we need to see.

 

Are you using Glider?

 

Rob



[TOPIC: post.html]
#9

alexk413x

[GLOBAL: userInfoPane.html]
alexk413x
  • Observer

  • 9 posts
  • Corona SDK

Here is the AnchorPoints sample app using just adb logcat.  I am not using Glider, I am using just the default download.  Hopefully this is all of the data from when I started the app and closed it.

 

11-15 15:17:29.935   470   826 I ActivityManager: START {act=android.intent.action.MAIN cat=[android.intent.categor
y.LAUNCHER] flg=0x10200000 cmp=com.gmail.alexk413x.AnchorPoints/com.ansca.corona.CoronaActivity u=0} from pid 832
11-15 15:17:29.967   832   832 W ResourceType: No package identifier when getting value for resource number 0x00000
000
11-15 15:17:29.990   470   481 I ActivityManager: Start proc com.gmail.alexk413x.AnchorPoints for activity com.gmai
l.alexk413x.AnchorPoints/com.ansca.corona.CoronaActivity: pid=20339 uid=10192 gids={1028}
11-15 15:17:30.029 20339 20339 E Trace   : error opening trace file: No such file or directory (2)
11-15 15:17:30.060 20339 20339 I ActivityThread: Pub com.gmail.alexk413x.AnchorPoints.files: com.ansca.corona.stora
ge.FileContentProvider
11-15 15:17:30.084 20339 20339 D dalvikvm: Trying to load lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/liblu
a.so 0x41490190
11-15 15:17:30.084 20339 20339 D dalvikvm: Added shared lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/liblua.
so 0x41490190
11-15 15:17:30.084 20339 20339 D dalvikvm: No JNI_OnLoad found in /data/data/com.gmail.alexk413x.AnchorPoints/lib/l
iblua.so 0x41490190, skipping init
11-15 15:17:30.084 20339 20339 D dalvikvm: Trying to load lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/libjn
lua5.1.so 0x41490190
11-15 15:17:30.084 20339 20339 D dalvikvm: Added shared lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/libjnlu
a5.1.so 0x41490190
11-15 15:17:30.084 20339 20339 D dalvikvm: Trying to load lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/libjn
lua5.1.so 0x41490190
11-15 15:17:30.084 20339 20339 D dalvikvm: Shared lib '/data/data/com.gmail.alexk413x.AnchorPoints/lib/libjnlua5.1.
so' already loaded in same CL 0x41490190
11-15 15:17:30.084 20339 20339 I dalvikvm: threadid=1: recursive native library load attempt (/data/data/com.gmail.
alexk413x.AnchorPoints/lib/libjnlua5.1.so)
11-15 15:17:30.084 20339 20339 D dalvikvm: Trying to load lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/libop
enal.so 0x41490190
11-15 15:17:30.092 20339 20339 I OpenAL_SLES: alc_opensles_init
11-15 15:17:30.092 20339 20339 D dalvikvm: Added shared lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/libopen
al.so 0x41490190
11-15 15:17:30.092 20339 20339 D dalvikvm: Trying to load lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/libmp
g123.so 0x41490190
11-15 15:17:30.092 20339 20339 D dalvikvm: Added shared lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/libmpg1
23.so 0x41490190
11-15 15:17:30.092 20339 20339 D dalvikvm: No JNI_OnLoad found in /data/data/com.gmail.alexk413x.AnchorPoints/lib/l
ibmpg123.so 0x41490190, skipping init
11-15 15:17:30.092 20339 20339 D dalvikvm: Trying to load lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/libvo
rbisidec.so 0x41490190
11-15 15:17:30.092 20339 20339 D dalvikvm: Added shared lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/libvorb
isidec.so 0x41490190
11-15 15:17:30.092 20339 20339 D dalvikvm: No JNI_OnLoad found in /data/data/com.gmail.alexk413x.AnchorPoints/lib/l
ibvorbisidec.so 0x41490190, skipping init
11-15 15:17:30.092 20339 20339 D dalvikvm: Trying to load lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/libal
mixer.so 0x41490190
11-15 15:17:30.092 20339 20339 D dalvikvm: Added shared lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/libalmi
xer.so 0x41490190
11-15 15:17:30.092 20339 20339 D dalvikvm: No JNI_OnLoad found in /data/data/com.gmail.alexk413x.AnchorPoints/lib/l
ibalmixer.so 0x41490190, skipping init
11-15 15:17:30.092 20339 20339 D dalvikvm: Trying to load lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/libco
rona.so 0x41490190
11-15 15:17:30.107 20339 20339 D dalvikvm: Added shared lib /data/data/com.gmail.alexk413x.AnchorPoints/lib/libcoro
na.so 0x41490190
11-15 15:17:30.217 20339 20339 D SensorManager: caller of registerListener:20339,sensor type:1
11-15 15:17:30.256 20339 20339 D libEGL  : loaded /vendor/lib/egl/libEGL_POWERVR_SGX540_120.so
11-15 15:17:30.256 20339 20339 D libEGL  : loaded /vendor/lib/egl/libGLESv1_CM_POWERVR_SGX540_120.so
11-15 15:17:30.264 20339 20339 D libEGL  : loaded /vendor/lib/egl/libGLESv2_POWERVR_SGX540_120.so
11-15 15:17:30.381 20339 20339 D OpenGLRenderer: Enabling debug mode 0
11-15 15:17:30.498   470   531 I ActivityManager: Displayed com.gmail.alexk413x.AnchorPoints/com.ansca.corona.Coron
aActivity: +529ms
11-15 15:17:30.560 20339 20354 D dalvikvm: Note: class Landroid/opengl/GLWrapperBase; has 250 unimplemented (abstra
ct) methods
11-15 15:17:30.568 20339 20354 V GLSurfaceView: glGetString(7937) returns PowerVR SGX 540;
11-15 15:17:30.592 20339 20354 V Corona  : > Class.forName: network.LuaLoader
11-15 15:17:30.592 20339 20354 V Corona  : < Class.forName: network.LuaLoader
11-15 15:17:30.592 20339 20354 V Corona  : Loading via reflection: network.LuaLoader
11-15 15:17:30.693 20339 20354 V Corona  : > Class.forName: CoronaProvider.licensing.google.LuaLoader
11-15 15:17:30.693 20339 20354 V Corona  : < Class.forName: CoronaProvider.licensing.google.LuaLoader
11-15 15:17:30.701 20339 20354 V Corona  : Loading via reflection: CoronaProvider.licensing.google.LuaLoader
11-15 15:17:57.521   783   783 D PortalService: Portal onReceive:
11-15 15:17:57.521   783   869 I PortalService: onHandleIntent() action android.intent.action.CLOSE_SYSTEM_DIALOGS
11-15 15:17:57.521   470   539 I ActivityManager: START {act=android.intent.action.MAIN cat=[android.intent.categor
y.HOME] flg=0x10200000 cmp=com.motorola.blur.home/.Launcher u=0} from pid 470
11-15 15:17:57.568 20339 20339 D SensorManager: caller of unregisterListener:20339,sensor type: ALL
11-15 15:17:57.607   832   832 W ResourceType: No package identifier when getting value for resource number 0x00000
000

 



[TOPIC: post.html]
#10

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,376 posts
  • Enterprise

Can you please try and build on of our stock sample apps and install it and see if it runs please?

 

Thanks

Rob



[TOPIC: post.html]
#11

alexk413x

[GLOBAL: userInfoPane.html]
alexk413x
  • Observer

  • 9 posts
  • Corona SDK

Is there a specific sample app you would like for me to try?

 

I just built and installed the hello world app using the corona simulator and the app starts up but I do not see the text or the image on the phone.

 

I have tried the anchor points and shape tumbler apps too.  All the apps seem to start and run without crashing.  I am noticing that sometimes I do not get a black screen completely but the images are rendered at stretched and disproportionate angles.  The image attached shows the shape tumbler app with the distortion. 

 

Attached File  IMG_20131115_175028_554.jpg   117.68KB   30 downloads



[TOPIC: post.html]
#12

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,376 posts
  • Enterprise

This is fixed as of daily build 2096.  For Starter/Basic subscribers, it will be fixed in the next public build.

 

Rob



[TOPIC: post.html]
#13

alexk413x

[GLOBAL: userInfoPane.html]
alexk413x
  • Observer

  • 9 posts
  • Corona SDK

Ok great thanks for the update Rob.




[topic_controls]
[/topic_controls]