Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

[Resolved] I get runtime error when I close Vungle interstitial ads on iOS device
Started by Naomi Aug 20 2013 12:23 PM

7 replies to this topic
vungle runtime error full screen ads interstitials
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

Naomi

[GLOBAL: userInfoPane.html]
Naomi
  • Corona Geek

  • 2,303 posts
  • Corona SDK

I'm wondering if I'm the only person seeing this runtime error (see below.) 
 
My app is built with Daily Build 1193 with iOS6.1 SDK and installed on iOS 6.x devices.
 
I get this runtime error every time I close the Vungle full screen interstitial ads from my iOS device (by tapping on the X button on upper left corner after the video plays all the way through.)  All other ads I run (Chartboost, Admob and iAds) do not trigger this runtime error.  All ads I run use the same sequence of code when they are closed, so I'd have to say this error comes from Vungle plugin code.
 
I'd like to hear whether or not any of you are seeing the same runtime error.
 
Naomi
 
 
<Warning>: Runtime error
    ?:0: attempt to index field '?' (a nil value)
    stack traceback:
        [C]: ?
        ?: in function '_listener'
        ?: in function <?:141>
        ?: in function <?:218>
<Warning>: errorMessage = "?:0: attempt to index field '?' (a nil value)"
<Warning>: Runtime error
    
    stack traceback:
        [C]: ?
        ?: in function '_listener'
        ?: in function <?:141>
        ?: in function <?:218>
<Warning>: errorMessage = "\nstack traceback:\n\t[C]: ?\n\t?: in function '_listener'\n\t?: in function <?:141>\n\t?: in function <?:218>"
 


[TOPIC: post.html]
#2

aukStudios

[GLOBAL: userInfoPane.html]
aukStudios
  • Corona Geek

  • 1,003 posts
  • Corona SDK

I've been using Vungle in Daily Build 1190, iOS 6.1 SDK on iOS 6.x devices without any issues.  I just tried it again right now, and it was fine.

 

It's always trickier to debug runtime errors when the information spit out by Lua uses '?' instead of a name for the function or variable causing the error.  Do the line numbers 141 and 218 mean anything to you?  You could also insert lots of print statements to isolate exactly which line is throwing the error.

 

I also wonder whether a tap on the X button bleeds through to underlying display objects with touch listeners?  If it does, then perhaps a display object behind it is receiving a touch and, because the scene is in a state when the object doesn't expect to receive a touch, it's doing something that's causing an error.  (When I use Vungle ads, the scene behind it is completely clear, so I have no idea of the touches bleed through.  Just a hypothesis.)

 

- Andrew



[TOPIC: post.html]
#3

Naomi

[GLOBAL: userInfoPane.html]
Naomi
  • Corona Geek

  • 2,303 posts
  • Corona SDK

Thank you so much, Andrew @aukStudios.  I really appreciate you taking the time to reply and let me know.  I have bazillions of print statements, trying to identify where this is coming from.  I guess I'll need to add even more and see if I can find it.

 

Thanks again.

 

Naomi



[TOPIC: post.html]
#4

Naomi

[GLOBAL: userInfoPane.html]
Naomi
  • Corona Geek

  • 2,303 posts
  • Corona SDK

Hey, Andrew @aukStudios, I found it.  Now that I knew it wasn't the Vungle plugin, I checked out every possible reason why, and I identified the issue.  Thanks again for all your help.

 

BTW, have you noticed a problem closing the Vungle interstitial ads on iPad?  With my iPad3, after the video finishes playing, tapping on X button on upper left corner doesn't close the ad screen right away.  It almost feels like the hot spot for the button is not right on the X button, and I kind of have to tap tap tap tap tap all around the X button area before it finally closes.

 

Naomi



[TOPIC: post.html]
#5

aukStudios

[GLOBAL: userInfoPane.html]
aukStudios
  • Corona Geek

  • 1,003 posts
  • Corona SDK

Actually yes, one of my testers mentioned that. It seems like the hit spot is a bit below where the X is. I never noticed it myself, but this tester pointed it out to me.

- Andrew

[TOPIC: post.html]
#6

Naomi

[GLOBAL: userInfoPane.html]
Naomi
  • Corona Geek

  • 2,303 posts
  • Corona SDK

Good to know that I wasn't the only one.  That said...  It's totally odd, and I don't get this, but I'm now able to close the ad by tapping on X only once.  Oh well, all is well. 

 

Naomi



[TOPIC: post.html]
#7

Alyousef

[GLOBAL: userInfoPane.html]
Alyousef
  • Enthusiast

  • 55 posts
  • Corona SDK

@Naomi, Can I ask you how did you resolve the issue? I know it's an old thread but I'm getting the exact same error and I hope to find an answer to the problem I'm facing. 

 

 

~Mustafa



[TOPIC: post.html]
#8

Naomi

[GLOBAL: userInfoPane.html]
Naomi
  • Corona Geek

  • 2,303 posts
  • Corona SDK

@Mustafa, actually I don't know how it fixes itself.  In fact, it seems like an on-and-off sort of thing.  Sometimes it closes right away, but other times it needs repeated taps before it finally does...  

 

Naomi




[topic_controls]
[/topic_controls]