Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

"display.captureScreen( saveToAlbum )" not working
Started by werdinteractive Feb 17 2010 06:59 AM

- - - - -
2 replies to this topic
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

werdinteractive

[GLOBAL: userInfoPane.html]
werdinteractive
  • Enthusiast

  • 76 posts
  • Corona SDK

According to the documentation if "display.captureScreen( saveToAlbum )" is false then I should be able to save into the photo gallery. I would assume that would be written like this; "display.captureScreen( false )". However, I have seen in other post that "display.captureScreen( true )" works in the simulator, but neither none of the above code works on the iphone. It would be great if someone could explain this.
uid: 4871 topic_id: 514 reply_id: 300514


[TOPIC: post.html]
#2

carlos m. icaza

[GLOBAL: userInfoPane.html]
carlos m. icaza
  • Corona Geek

  • 2,992 posts
  • Alumni



let me look into it.

can you post sample of your code so we can see ?

carlos
uid: 24 topic_id: 514 reply_id: 1003


[TOPIC: post.html]
#3

werdinteractive

[GLOBAL: userInfoPane.html]
werdinteractive
  • Enthusiast

  • 76 posts
  • Corona SDK

Thank you so much for responding. The screen capture began to work after I had removed some code that was saving the file and making a thumbnail after this action was performed, which was strange because that code worked fine on its own. The documentation that stated that I needed to declare the statement as false seemed to be wrong and might need to be changed. On a side note, I did have a question that I have not been able to solve. If you could link me to any code that would allow me to send picture messages I would be very grateful.

If anyone else has problems in the future, the code "display.captureScreen( true )" does work in the simulator and on the iphone.

uid: 4871 topic_id: 514 reply_id: 1004



[topic_controls]
[/topic_controls]