Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Android builds with Mac does not install on Android devices.
Started by Aidin Jun 01 2013 09:29 AM

- - - - -
74 replies to this topic
[TOPIC CONTROLS]
Page 3 of 3 1 2 3
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#51

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

My OS version is 10.8.4 and I'm trying install my app on a HTC Amaze 4G. My Corona simulator version is 2013.1135 (2013.6.3) and my phone's Android version is 4.0.3 and I posted info about my Java version earlier.

 

I've seen that another problem could be folder names, folder names that I have are:

 

menu
music
juice
sfx
 

Also my build.settings file is:

 

settings =
{
    iphone =
    {
        plist =
        {
	    	CFBundleIconFile = "Icon.png",
		    CFBundleIconFiles = 
	    	{
				"Icon.png" , 
				"Icon@2x.png" , 
				"Icon-72.png" , 
				"Icon-72@2x.png" , 
                                "Icon-Small-50.png" , 
                                "Icon-Small.png" , 
                                "Icon-Small@2x.png"
		    },
		    UIAppFonts =
				{
					"Tahoma.ttf"
				}
	        },
	    },

    orientation =
    {
        default = "portrait",
        supported =
        {
            "portrait", "portraitUpsideDown"
        }
    },
}

and I'm building to Desktop folder of my Mac.



[TOPIC: post.html]
#52

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

I've seen another topic's suggestion and tried swapping my build.settings file to the one from hello world, same error.

 

I'm willing to hand over the build file, if you want.



[TOPIC: post.html]
#53

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

[TOPIC: post.html]
#54

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,072 posts
  • Enterprise

Have you read this thread?

 

http://forums.coronalabs.com/topic/29712-android-failure-install-parse-failed-certificate-encoding/

 

It's got some suggestions to try and determine if is a problem with your Java setup or not.   Also try doing a:

 

adb uninstall com.lk.shm

 

before you do your adb install.

Rob



[TOPIC: post.html]
#55

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

Have you read this thread?

 

http://forums.coronalabs.com/topic/29712-android-failure-install-parse-failed-certificate-encoding/

 

It's got some suggestions to try and determine if is a problem with your Java setup or not.   Also try doing a:

 

adb uninstall com.lk.shm

 

before you do your adb install.

Rob

 

Thanks Rob for the reply.

 

I actually did read that topic and repeated posts that I've made before your reply was an effort to provide answers to questions people asked the OP (original poster) of that topic in order to help the process.

 

Please do correct me if I'm wrong but I think the OP of that topic did not reach an answer, right?



[TOPIC: post.html]
#56

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,072 posts
  • Enterprise

Did you try the  uninstall call?



[TOPIC: post.html]
#57

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

Hi,

 

Sorry for the long delay, again. Can't work as good as before.

 

I tried adb uninstall and it just said "Failed" in the Terminal. So I removed them manually via the phone.

 

I upgraded to Mavericks and when I tried to run my game in Corona Simulator it said that it doesn't have Java, so I let it to download and checked via Java -version and it said 1.6.0_65.

 

I tried to build again and install via adb install, replied the same "INSTALL_PARSE_FAILED_CERTIFICATE_ENCODING" error.

 

What should I do?



[TOPIC: post.html]
#58

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

In another topic there was a suggestion of signing the apk file manually, I did that and still the same INSTALL_PARSE_FAILED_CERTIFICATE_ENCODING error is what I get.

 

I'm to the point that would be glad to give you guys my whole project, if you want.

 

Thanks.



[TOPIC: post.html]
#59

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

I renamed the apk file to zip and extracted it and there was two interesting things that caught my attention:

 

1) There was a file named "icon" that has no extension and it's size is zero. Is this normal?

 

2) I have some files that I have folders with same name. For example. I have sfx.lua and a folder called sfx in the same structure. Can they make problem?

 

3) I remember there was a problem with case sensitivity in Android builds, do they still exist to this day and age?



[TOPIC: post.html]
#60

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

Apparently problem was not related to my folder names as I changed them and problem persists.

 

Why is this bug this hard to find? It's so frustrating, everytime I want to work on this game, I get stuck with this bug and can't get anything done.



[TOPIC: post.html]
#61

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,072 posts
  • Enterprise

Folder names can cause problems, but having an sfx folder and an sfx.lua shouldn't be an issue.  Folder names with non-ASCII characters can cause issues (and not just within the project).  On iOS, a folder name "resources" causes issues.

 

Android (and iOS) devices file systems are case sensitive, Windows and the Mac's filesystems are not.  But this would result in your app getting a black screen (crashing) when you run it and the error would be obvious in your adb logcat.

 

You are having a signing issue, so sending us your project isn't going to do much good.  With your upgrade to Mavericks and the changes to java, humor me and try to build and install the Hello World sample app.  Take screen shots if the Corona build screen before you click the build button so I can see what's set there.

 

Rob



[TOPIC: post.html]
#62

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

Hi man,

 

First of all let me thank you for your constant support.

 

Following your advice, here is screenshot of my build window:

 

https://www.dropbox.com/s/1r4t9ho2kvdl1ng/Screenshot%202013-12-01%2023.14.07.png

 

And results is that it got installed with "Success" in Terminal.

 

What now?



[TOPIC: post.html]
#63

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,072 posts
  • Enterprise

Were you able to use adb install to install the app on your device?

 

If so, then there is a problem with your  app some where.  If that failed, we have a keystore problem, however, your screen shot shows you are using a debug keystore  and that shouldn't be generating any errors.

 

What is the result of the command line command:   java -version

 

Thanks

Rob



[TOPIC: post.html]
#64

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

Were you able to use adb install to install the app on your device?

 

If so, then there is a problem with your  app some where.  If that failed, we have a keystore problem, however, your screen shot shows you are using a debug keystore  and that shouldn't be generating any errors.

 

What is the result of the command line command:   java -version

 

Thanks

Rob

 

Yes, I installed the HelloWorld app with adb install.

 

Java -version results this:

 

java version "1.6.0_65"
Java™ SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot™ 64-Bit Server VM (build 20.65-b04-462, mixed mode)


[TOPIC: post.html]
#65

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,072 posts
  • Enterprise

Then there is an issue with your app itself.  If you want to zip it up and get it to me somehow (uploading to dropbox and sending me a link to it would be fine), then I'll see if I can see what's causing the problem.

 

Rob



[TOPIC: post.html]
#66

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

Then there is an issue with your app itself.  If you want to zip it up and get it to me somehow (uploading to dropbox and sending me a link to it would be fine), then I'll see if I can see what's causing the problem.

 

Rob

 


That would be splendid. How can I give the project to you privately? Can't seem to find PM feature anywhere.



[TOPIC: post.html]
#67

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,072 posts
  • Enterprise

You can email me at rob at coronalabs.com



[TOPIC: post.html]
#68

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,072 posts
  • Enterprise

Actually it was the "Icon" file.  I removed it from your folder and it installed just fine.  I'm not sure what it's doing in your folder, but it's creating issue.  Simply remove it and you should be good to go.

 

Rob



[TOPIC: post.html]
#69

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

Thanks man,

 

I have 11 icon files, which one are you referring to?

 

My suspicion was for a file named "icon" with no extension in the apk file, if you are referring to the same file, I don't have it in my project but it is generated in the apk file.

 

Thanks again,

Cheers.



[TOPIC: post.html]
#70

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,072 posts
  • Enterprise

Yes, the Icon file with no extension.  And yes, it's in your project.  It was in the zip file and as soon as I removed it, your app installed correctly.

 

Rob



[TOPIC: post.html]
#71

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

Thanks but how could you see it, are you using OS X? I can see it with "ls" command in Terminal but can't see it in Finder.



[TOPIC: post.html]
#72

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,072 posts
  • Enterprise

Finder is probably confusing it with your Icon.png file by hiding the extensions.  I saw it in the file side bar on Sublime Text 3.  But you will probably see it using "ls" from the command line.  Just do a:

 

rm Icon

 

from the command line while in the right folder to get rid of it.

 

Rob



[TOPIC: post.html]
#73

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

YES, YOU ARE THE BEST, MAN! Love you! Can't believe it that this nasty bug is finally "killed", may the force be with you!

 

I found where that Icon file comes from, I put Icon on folder of my project (Finder "feature") and it was that very same file ... GRRRR!

 

Thanks again, finally something good happened.

 

-=-=-=-=-

 

BTW, how do you navigate files with Sublime Text? I thought it's only for text editing.



[TOPIC: post.html]
#74

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 26,072 posts
  • Enterprise

If you open a folder instead of an individual file, there will be a sidebar on the left that lists the files in the folder, so you quickly open the text files.  You can also right click to rename, delete etc.  If the sidebar isn't showing then you can do a View->Side Bar->Show Side Bar.

 

Rob



[TOPIC: post.html]
#75

Aidin

[GLOBAL: userInfoPane.html]
Aidin
  • Contributor

  • 401 posts
  • Corona SDK

Thanks man, you are SO awesome!




[topic_controls]
Page 3 of 3 1 2 3
 
[/topic_controls]