Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Coronasdk-2012.971 To
Started by waikisstudio Apr 10 2013 11:03 PM

5 replies to this topic
migration old versions support
[TOPIC CONTROLS]
This topic has been archived. This means that you cannot reply to this topic.
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#1

waikisstudio

[GLOBAL: userInfoPane.html]
waikisstudio
  • Observer

  • 1 posts
  • Corona SDK

Hi,

I have huge problem i developed program on CoronaSDK-2012.971 and my client said everything is ok, but because of lag on his side my license run out, he agreed to take program for testing in Corona free and later buy license to export, but after new update all my program is broken.

I have 2 questions:

Is there any way to get CoronaSDK-2012.971 for mac ?
If i get it, will i be able to Compile program ?
 

thanks



[TOPIC: post.html]
#2

DavidRangel

[GLOBAL: userInfoPane.html]
DavidRangel
  • Moderator

  • 888 posts
  • Corona Staff

waikstudio - if you go to our download page you will see a link that says "Public Release Archive". If you click on it, you will see links to past public releases, including 971. Here is the link too: http://developer.coronalabs.com/downloads/archive

 

You will be able to build as long as you have an active subscription.



[TOPIC: post.html]
#3

tim12332000

[GLOBAL: userInfoPane.html]
tim12332000
  • Observer

  • 10 posts
  • Corona SDK

helooo i have a program on CoronaSDK-2012.971 , but i have some woring like this  https://drive.google.com/file/d/0B5DhNDtxRQuYYXFCa0xtVnVBaUk/edit?usp=sharing
I can look provision , but I cant choose provision... plz help me thx~~



[TOPIC: post.html]
#4

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,376 posts
  • Enterprise

Apple changed something on how Provisioning Profiles work recently.  You need to use Corona SDK build 2014.2393a or later to build for Apple.  Starting with build 2000, we switched to our Graphics 2.0 engine which is not 100% compatible with the Graphics 1.0 engine used in builds before.    You will need to read this guide:   http://docs.coronalabs.com/guide/graphics/migration.html

to help migrate your app to the new API calls.

 

There have been significant changes in other API calls since 971 so you should expect to put some effort into converting your app.  We cannot patch old builds. 

 

Rob



[TOPIC: post.html]
#5

tim12332000

[GLOBAL: userInfoPane.html]
tim12332000
  • Observer

  • 10 posts
  • Corona SDK

thx Rob~ so use corona 971 is Impossible right?  upgrade corona is a Big trouble for me~~ :(  so said...



[TOPIC: post.html]
#6

Rob Miracle

[GLOBAL: userInfoPane.html]
Rob Miracle
  • Moderator

  • 25,376 posts
  • Enterprise

You cannot submit to Apple with 971.

 

Rob




[topic_controls]
[/topic_controls]