Jump to content

[TOPIC: topicViewTemplate]
[GLOBAL: userSmallPhoto]
Photo

Amazon Ads Plugin Launched!
Started by Gremlin Interactive May 19 2014 10:58 AM

85 replies to this topic
[TOPIC CONTROLS]
« Page 4 of 4 2 3 4
[/TOPIC CONTROLS]
[modOptionsDropdown]
[/modOptionsDropdown]
[reputationFilter]
[TOPIC: post.html]
#76

Guest_Gremlin Interactive_*

[GLOBAL: userInfoPane.html]
Guest_Gremlin Interactive_*
  • Guests

Did you take the plugin down from your store? Say it ain't so :(
I'm loving the chartboost plugin and was looking forward to adding amazon ads as well.


Hey Jorge, just maintenance, don't worry.

[TOPIC: post.html]
#77

Guest_Gremlin Interactive_*

[GLOBAL: userInfoPane.html]
Guest_Gremlin Interactive_*
  • Guests

The maintenance work on the amazon ad's plugin has completed, the plugin is available for sale from our store again.

Thanks for your patience. 



[TOPIC: post.html]
#78

Alan QuizTix

[GLOBAL: userInfoPane.html]
Alan QuizTix
  • Enterprise
  • PipPipPipPipPipPip
  • 132 posts
  • Jedi

Is the plugin working on iOS for other people? Whenever I try to build project that includes it, I still get a build error (albeit a different one to before):

/Users/me/Builds/MyApp.app/.build/libtemplate/Builder.lua:310: <error>{"status":256,"message":"Undefined symbols for architecture armv7:\n  \"_OBJC_CLASS_$_CTTelephonyNetworkInfo\", referenced from:\n      objc-class-ref in libAmazonAd.a(AMAdConfiguration.o)\nld: symbol(s) not found for architecture armv7\nclang: error: linker command failed with exit code 1 (use -v to see invocation)"}</error>
stack traceback:
	[C]: ?
	[C]: in function 'assert'
	/Users/me/Builds/MyApp.app/.build/libtemplate/Builder.lua:310: in function 'checkError'
	/Users/me/Builds/MyApp.app/.build/libtemplate/Builder.lua:333: in function 'build'
	?: in function 'buildExe'
	?: in function <?:624>

The many other plugins in my app are fine, just the AmazonAds one that causes problems.

 

My build.settings file includes this:

plugins =
    { 
		["plugin.amazonAds"] = { publisherId = "com.deleurapps"},
	}

and my main.lua has this:

-- Initialize the Amazon Ads library
amazonAds = require "plugin.amazonAds"
amazonAds.init({ appKey = "myKeyString", licenseKey = "ABCDE-FGHIJK-LMNOP-QRSTU"}, amazonAdListener)

Have I missed something by mistake? Does it work on iOS for anyone else? I know that Gremlin are no longer supporting their plugins, but this one was made by deleurapps so if they could let me know what the situation is that would be helpful.



[TOPIC: post.html]
#79

ingemar

[GLOBAL: userInfoPane.html]
ingemar
  • Enterprise
  • PipPipPipPipPipPip
  • 2,176 posts
  • Jedi

The error you're getting looks like a misconfiguration of the required frameworks for the plugin. The CoreTelephony.framework seems to be missing from your project.

 

Side note

One problem with the situation is that Deleurapps were using Gremlin's services for sales and license servers, and I have no idea how that will affect the Amazon Ads plugin in production. Gremlin have removed the license requirements for their own plugins and I'm not sure if the same goes for the Amazon Ads plugin. I'd assume since Gremlin has stepped out of the Corona Plugin business that the license validation they were performing has ceased for all of the plugins, including AmazonAds.

 

Only Deleurapps will be able to answer this though.

 

Luckily I've developed my own Amazon Ads plugin. However I've only made the Android version so far as I use other networks for iOS.



[TOPIC: post.html]
#80

Stephen Lewis

[GLOBAL: userInfoPane.html]
Stephen Lewis
  • Pro
  • PipPipPipPipPipPip
  • 706 posts
  • Jedi

I would like to know the status of the Amazon ad plugin as well now that Gremlin Interactive is out of the plugin business.



[TOPIC: post.html]
#81

deleurapps

[GLOBAL: userInfoPane.html]
deleurapps
  • Enterprise
  • PipPipPipPipPipPip
  • 143 posts
  • Jedi

Hello!

 

Right now I am trying to contact the Corona team to make my own deal similar to what Gremlin Interactive had. I want to continue selling the plugin, and gremlin backing out is a little bump in the road. If I do set up my own store, everyone who bought the amazon ads plugin will still have access to it. Right now I believe that gremlin said that amazon ads plugin should continue to work for those who already purchased it.

Best,

DeleurApps



[TOPIC: post.html]
#82

Jorge Sanchez

[GLOBAL: userInfoPane.html]
Jorge Sanchez
  • Basic
  • PipPip
  • 28 posts
  • Member

This is super. Hopefully you can get a deal in place and even add more plugins down the road.



[TOPIC: post.html]
#83

deleurapps

[GLOBAL: userInfoPane.html]
deleurapps
  • Enterprise
  • PipPipPipPipPipPip
  • 143 posts
  • Jedi

That's what I'm hoping for. I have about 10 different plugins ready to be published



[TOPIC: post.html]
#84

prmobiapp

[GLOBAL: userInfoPane.html]
prmobiapp
  • Basic
  • PipPip
  • 26 posts
  • Member

Store is not working. I couldn't buy the amazon ads plugin. Please update me!

 

http://gremlininteractive.com/product/amazon-ads-plugin-for-the-corona-sdk/



[TOPIC: post.html]
#85

Alan QuizTix

[GLOBAL: userInfoPane.html]
Alan QuizTix
  • Enterprise
  • PipPipPipPipPipPip
  • 132 posts
  • Jedi

@prmobiapp

 

GremlinInteractive are no longer working with Corona:  

http://forums.coronalabs.com/topic/50786-important-plugin-updates-license-free-please-rebuild-your-apps/

 

If you read deleurapps post a few posts before yours, he is trying to work something out for the amazonads plugin.



[TOPIC: post.html]
#86

prmobiapp

[GLOBAL: userInfoPane.html]
prmobiapp
  • Basic
  • PipPip
  • 26 posts
  • Member

@Corona1634: Thanks, we recently released our Dog puzzle game in Amazon store for both phone and Fire TV. Still we are waiting to incorporate Amazon Ads and Game circle to qualify for Amazon select program.

 

@deleurapps: Could you please update us about Amazon Ads and Game circle plugin? Thanks!




[topic_controls]
« Page 4 of 4 2 3 4
 
[/topic_controls]